# CVE-2025-30207: Kirby vulnerable to path traversal in the router for PHP's built-in server

> Attackers can determine file existence outside the document root via path traversal in Kirby's PHP built-in server router, affecting local development setups.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2025
- **Updated:** 13 May 2025
- **Also known as:** GHSA-9p3p-w5jf-8xxg

## What is CVE-2025-30207?

CVE-2025-30207 is a low-severity path traversal vulnerability in getkirby kirby, published on 13 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby setups that use PHP's built-in server. Such setups are commonly only used during local development. Sites that use other server software (such as Apache, nginx or Caddy) are not affected. A missing path traversal check allowed attackers to navigate all files on the server that were accessible to the PHP process, including files outside of the Kirby installation. The vulnerable implementation delegated all existing files to PHP, including existing files outside of the document root. This leads to a different response that allows attackers to determine whether the requested file exists. Because Kirby's router only delegates such requests to PHP and does not load or execute them, contents of the files were not exposed as PHP treats requests to files outside of the document root as invalid. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, the maintainers of Kirby have updated the router to check if existing static files are within the document root. Requests to files outside the document root are treated as page requests of the error page and will no longer allow to determine whether the file exists or not.

Weakness: CWE-23 (Relative Path Traversal), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-30207?

6 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 3.9.8.3 |
| `getkirby/cms` | Packagist | All versions | 3.9.8.3 |
| `getkirby/cms` | Packagist | From 3.10.0 | 3.10.1.2 |
| `getkirby/cms` | Packagist | From 3.10.0 | 3.10.1.2 |
| `getkirby/cms` | Packagist | From 4.0.0 | 4.7.1 |
| `getkirby/cms` | Packagist | From 4.0.0 | 4.7.1 |

Products: Getkirby Kirby.

## How do I fix CVE-2025-30207?

Upgrade getkirby/cms to a fixed version for your release line: 3.9.8.3, 3.10.1.2 or 4.7.1.

## Is CVE-2025-30207 being exploited?

There is no known exploitation of CVE-2025-30207 in the wild and no public exploit code.

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2021-29460](https://insights.sbomify.com/CVE-2021-29460/): Cross-site scripting (XSS) from unsanitized uploaded SVG files (high 7.6)
- [CVE-2023-38489](https://insights.sbomify.com/CVE-2023-38489/): Kirby vulnerable to Insufficient Session Expiration after a password change (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30207 and fix it if it is affected.

What it is: CVE-2025-30207 is a low-severity path traversal vulnerability in getkirby kirby, published on 13 May 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30207 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 3.9.8.3
- getkirby/cms (Packagist): affected all versions; fixed in 3.9.8.3
- getkirby/cms (Packagist): affected from 3.10.0; fixed in 3.10.1.2
- getkirby/cms (Packagist): affected from 3.10.0; fixed in 3.10.1.2
- getkirby/cms (Packagist): affected from 4.0.0; fixed in 4.7.1
- getkirby/cms (Packagist): affected from 4.0.0; fixed in 4.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30207/ (Markdown: https://insights.sbomify.com/CVE-2025-30207/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30207
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30207
- OSV: https://osv.dev/vulnerability/CVE-2025-30207

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30207/
Summaries are generated and may contain mistakes; the official description above is the record.
