CVE-2025-30212 Frappe has possibility of SQL injection due to improper validations

Medium 6.6 Published Updated

Attackers can exploit improper validations to perform SQL injection and access sensitive information in the Frappe web application framework.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-30212?

CVE-2025-30212 is a medium-severity SQL injection vulnerability in frappe, published on 25 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Frappe is a full-stack web application framework. An SQL Injection vulnerability has been identified in Frappe Framework prior to versions 14.89.0 and 15.51.0 which could allow a malicious actor to access sensitive information. Versions 14.89.0 and 15.51.0 fix the issue. Upgrading is required; no other workaround is present.

Weakness: CWE-89

Which versions are affected by CVE-2025-30212?

5 open source packages ship an affected version, including frappe. It affects 1 product.

PackageAffectedFixed in
frappe PyPIAll versions14.89.0, 15.51.0
frappe PyPIAll versions14.89.0
frappe PyPIAll versions14.89.0
frappe PyPIFrom 15.0.015.51.0
frappe PyPIFrom 15.0.015.51.0

Products include Frappe Frappe.

How do I fix CVE-2025-30212?

Upgrade frappe to a fixed version for your release line: 14.89.0 or 15.51.0.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2025-30212 being exploited?

There is no known exploitation of CVE-2025-30212 in the wild and no public exploit code.

Sources

Also known as GHSA-3hj6-r5c9-q8f3, PYSEC-2026-1390.

Is CVE-2025-30212 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free