{"answers":{"affected":"5 open source packages ship an affected version, including frappe. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-30212 in the wild and no public exploit code.","fix":"Upgrade frappe to a fixed version for your release line: 14.89.0 or 15.51.0.","what":"CVE-2025-30212 is a medium-severity SQL injection vulnerability in frappe, published on 25 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-30212 and fix it if it is affected.\n\nWhat it is: CVE-2025-30212 is a medium-severity SQL injection vulnerability in frappe, published on 25 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-30212 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- frappe (PyPI): affected all versions; fixed in 14.89.0, 15.51.0\n- frappe (PyPI): affected all versions; fixed in 14.89.0\n- frappe (PyPI): affected all versions; fixed in 14.89.0\n- frappe (PyPI): affected from 15.0.0; fixed in 15.51.0\n- frappe (PyPI): affected from 15.0.0; fixed in 15.51.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-30212/ (Markdown: https://insights.sbomify.com/CVE-2025-30212/index.md)","id":"CVE-2025-30212","markdown":"https://insights.sbomify.com/CVE-2025-30212/index.md","name":"CVE-2025-30212","record":{"aliases":["GHSA-3hj6-r5c9-q8f3","PYSEC-2026-1390"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Frappe web framework","requires_auth":"none","summary":"Attackers can exploit improper validations to perform SQL injection and access sensitive information in the Frappe web application framework.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"frappe","vendor":"frappe"}],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Frappe is a full-stack web application framework. An SQL Injection vulnerability has been identified in Frappe Framework prior to versions 14.89.0 and 15.51.0 which could allow a malicious actor to access sensitive information. Versions 14.89.0 and 15.51.0 fix the issue. Upgrading is required; no other workaround is present.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Frappe has possibility of SQL injection due to improper validations","id":"CVE-2025-30212","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2025"},"n_packages":5,"n_references":3,"next":{"headline":"Frappe has Possibility of Remote Code Execution due to improper validation","id":"CVE-2025-30213"},"packages":[{"ecosystem":"PyPI","fixed":["14.89.0","15.51.0"],"introduced":["0","15.0.0"],"last_affected":[],"package":"frappe","purl":"pkg:pypi/frappe","source":"PYSEC-2026-1390"},{"ecosystem":"PyPI","fixed":["14.89.0"],"introduced":["0"],"last_affected":[],"package":"frappe","purl":null,"source":"GHSA-3hj6-r5c9-q8f3"},{"ecosystem":"PyPI","fixed":["14.89.0"],"introduced":["0"],"last_affected":[],"package":"frappe","purl":"pkg:pypi/frappe","source":"GHSA-3hj6-r5c9-q8f3"},{"ecosystem":"PyPI","fixed":["15.51.0"],"introduced":["15.0.0"],"last_affected":[],"package":"frappe","purl":null,"source":"GHSA-3hj6-r5c9-q8f3"},{"ecosystem":"PyPI","fixed":["15.51.0"],"introduced":["15.0.0"],"last_affected":[],"package":"frappe","purl":"pkg:pypi/frappe","source":"GHSA-3hj6-r5c9-q8f3"}],"prev":{"headline":"KEX init error results with excessive memory usage","id":"CVE-2025-30211"},"products":["frappe"],"published":"2025-03-25","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-14965","kev_date_added":null,"published":"2019-08-12"},{"cvss_score":9.3,"headline":"Frappe has a SQL injection in bulk_update","id":"CVE-2026-35614","kev_date_added":null,"published":"2026-04-07"},{"cvss_score":9.3,"headline":"Frappe SQL Injection due to improper field sanitization","id":"CVE-2026-31877","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":9.1,"headline":"Frappe may be vulnerable remote code execution due to server-side template injection","id":"CVE-2025-68929","kev_date_added":null,"published":"2025-12-29"},{"cvss_score":8.8,"headline":"SQL injection in n/a","id":"CVE-2019-14966","kev_date_added":null,"published":"2019-08-12"},{"cvss_score":8.8,"headline":"SQL injection in n/a","id":"CVE-2017-1000120","kev_date_added":null,"published":"2017-10-04"},{"cvss_score":8.7,"headline":"Frappe has the possibility of SQL Injection due to improper validations","id":"CVE-2025-55732","kev_date_added":null,"published":"2025-08-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-25","vendors":["frappe"]},"summary":"Attackers can exploit improper validations to perform SQL injection and access sensitive information in the Frappe web application framework.","url":"https://insights.sbomify.com/CVE-2025-30212/"}