# CVE-2025-30213: Frappe has Possibility of Remote Code Execution due to improper validation

> A system user can achieve remote code execution in the Frappe framework by creating specific documents, requiring an upgrade to fix.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2025
- **Updated:** 25 Mar 2025
- **Also known as:** GHSA-v342-4xr9-x3q3, PYSEC-2026-1393

## What is CVE-2025-30213?

CVE-2025-30213 is a medium-severity code injection vulnerability in frappe, published on 25 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Frappe is a full-stack web application framework. Prior to versions 14.91.0 and 15.52.0, a system user was able to create certain documents in a specific way that could lead to remote code execution. Versions 14.9.1 and 15.52.0 contain a patch for the vulnerability. There's no workaround; an upgrade is required.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-30213?

5 open source packages ship an affected version, including frappe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `frappe` | PyPI | All versions | 14.91.0, 15.52.0 |
| `frappe` | PyPI | All versions | 14.91.0 |
| `frappe` | PyPI | All versions | 14.91.0 |
| `frappe` | PyPI | From 15.0.0 | 15.52.0 |
| `frappe` | PyPI | From 15.0.0 | 15.52.0 |

Products: Frappe Frappe.

## How do I fix CVE-2025-30213?

Upgrade frappe to a fixed version for your release line: 14.91.0 or 15.52.0.

## Is CVE-2025-30213 being exploited?

There is no known exploitation of CVE-2025-30213 in the wild and no public exploit code.

## Other vulnerabilities in frappe

- [CVE-2019-14965](https://insights.sbomify.com/CVE-2019-14965/): Code injection in n/a (critical 9.8)
- [CVE-2026-35614](https://insights.sbomify.com/CVE-2026-35614/): Frappe has a SQL injection in bulk_update (critical 9.3)
- [CVE-2026-31877](https://insights.sbomify.com/CVE-2026-31877/): Frappe SQL Injection due to improper field sanitization (critical 9.3)
- [CVE-2025-68929](https://insights.sbomify.com/CVE-2025-68929/): Frappe may be vulnerable remote code execution due to server-side template injection (critical 9.1)
- [CVE-2019-14966](https://insights.sbomify.com/CVE-2019-14966/): SQL injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30213 and fix it if it is affected.

What it is: CVE-2025-30213 is a medium-severity code injection vulnerability in frappe, published on 25 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30213 in the wild and no public exploit code.

Affected packages and fixed versions:
- frappe (PyPI): affected all versions; fixed in 14.91.0, 15.52.0
- frappe (PyPI): affected all versions; fixed in 14.91.0
- frappe (PyPI): affected all versions; fixed in 14.91.0
- frappe (PyPI): affected from 15.0.0; fixed in 15.52.0
- frappe (PyPI): affected from 15.0.0; fixed in 15.52.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30213/ (Markdown: https://insights.sbomify.com/CVE-2025-30213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30213
- OSV: https://osv.dev/vulnerability/CVE-2025-30213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30213/
Summaries are generated and may contain mistakes; the official description above is the record.
