CVE-2025-30214 Frappe vulnerable to information disclosure leading to account takeover
Crafted requests in Frappe framework allow information disclosure, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-30214?
CVE-2025-30214 is a high-severity vulnerability in frappe, published on 25 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Frappe is a full-stack web application framework. Prior to versions 14.89.0 and 15.51.0, making crafted requests could lead to information disclosure that could further lead to account takeover. Versions 14.89.0 and 15.51.0 fix the issue. There's no workaround to fix this without upgrading.
Which versions are affected by CVE-2025-30214?
5 open source packages ship an affected version, including frappe. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
frappe PyPI | All versions | 14.89.0, 15.51.0 |
frappe PyPI | All versions | 14.89.0 |
frappe PyPI | All versions | 14.89.0 |
frappe PyPI | From 15.0.0 | 15.51.0 |
frappe PyPI | From 15.0.0 | 15.51.0 |
Products include Frappe Frappe.
How do I fix CVE-2025-30214?
Upgrade frappe to a fixed version for your release line: 14.89.0 or 15.51.0.
Is CVE-2025-30214 being exploited?
There is no known exploitation of CVE-2025-30214 in the wild and no public exploit code.
Other vulnerabilities in frappe
- CVE-2019-14965 Code injection in n/a
- CVE-2026-35614 Frappe has a SQL injection in bulk_update
- CVE-2026-31877 Frappe SQL Injection due to improper field sanitization
- CVE-2025-68929 Frappe may be vulnerable remote code execution due to server-side template injection
- CVE-2019-14966 SQL injection in n/a
Sources
Also known as GHSA-qrv3-jc3h-f3m6, PYSEC-2026-1392.