# CVE-2025-30214: Frappe vulnerable to information disclosure leading to account takeover

> Crafted requests in Frappe framework allow information disclosure, potentially leading to account takeover.

- **Severity:** High 8.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2025
- **Updated:** 25 Mar 2025
- **Also known as:** GHSA-qrv3-jc3h-f3m6, PYSEC-2026-1392

## What is CVE-2025-30214?

CVE-2025-30214 is a high-severity vulnerability in frappe, published on 25 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Frappe is a full-stack web application framework. Prior to versions 14.89.0 and 15.51.0, making crafted requests could lead to information disclosure that could further lead to account takeover. Versions 14.89.0 and 15.51.0 fix the issue. There's no workaround to fix this without upgrading.

Weakness: CWE-287 (Improper Authentication), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-30214?

5 open source packages ship an affected version, including frappe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `frappe` | PyPI | All versions | 14.89.0, 15.51.0 |
| `frappe` | PyPI | All versions | 14.89.0 |
| `frappe` | PyPI | All versions | 14.89.0 |
| `frappe` | PyPI | From 15.0.0 | 15.51.0 |
| `frappe` | PyPI | From 15.0.0 | 15.51.0 |

Products: Frappe Frappe.

## How do I fix CVE-2025-30214?

Upgrade frappe to a fixed version for your release line: 14.89.0 or 15.51.0.

## Is CVE-2025-30214 being exploited?

There is no known exploitation of CVE-2025-30214 in the wild and no public exploit code.

## Other vulnerabilities in frappe

- [CVE-2019-14965](https://insights.sbomify.com/CVE-2019-14965/): Code injection in n/a (critical 9.8)
- [CVE-2026-35614](https://insights.sbomify.com/CVE-2026-35614/): Frappe has a SQL injection in bulk_update (critical 9.3)
- [CVE-2026-31877](https://insights.sbomify.com/CVE-2026-31877/): Frappe SQL Injection due to improper field sanitization (critical 9.3)
- [CVE-2025-68929](https://insights.sbomify.com/CVE-2025-68929/): Frappe may be vulnerable remote code execution due to server-side template injection (critical 9.1)
- [CVE-2019-14966](https://insights.sbomify.com/CVE-2019-14966/): SQL injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30214 and fix it if it is affected.

What it is: CVE-2025-30214 is a high-severity vulnerability in frappe, published on 25 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30214 in the wild and no public exploit code.

Affected packages and fixed versions:
- frappe (PyPI): affected all versions; fixed in 14.89.0, 15.51.0
- frappe (PyPI): affected all versions; fixed in 14.89.0
- frappe (PyPI): affected all versions; fixed in 14.89.0
- frappe (PyPI): affected from 15.0.0; fixed in 15.51.0
- frappe (PyPI): affected from 15.0.0; fixed in 15.51.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30214/ (Markdown: https://insights.sbomify.com/CVE-2025-30214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30214
- OSV: https://osv.dev/vulnerability/CVE-2025-30214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30214/
Summaries are generated and may contain mistakes; the official description above is the record.
