CVE-2025-30215 NATS-Server Fails to Authorize Certain Jetstream Admin APIs
Attackers with JetStream management permissions can perform unauthorized administrative actions, including data destruction, on assets in other accounts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-30215?
CVE-2025-30215 is a critical missing authorization vulnerability in nats-io nats-server, published on 15 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
NATS-Server is a High-Performance server for NATS.io, the cloud and edge native messaging system. In versions starting from 2.2.0 but prior to 2.10.27 and 2.11.1, the management of JetStream assets happens with messages in the $JS. subject namespace in the system account; this is partially exposed into regular accounts to allow account holders to manage their assets. Some of the JS API requests were missing access controls, allowing any user with JS management permissions in any account to perform certain administrative actions on any JS asset in any other account. At least one of the unprotected APIs allows for data destruction. None of the affected APIs allow disclosing stream contents. This vulnerability is fixed in v2.11.1 or v2.10.27.
Which versions are affected by CVE-2025-30215?
6 open source packages ship an affected version, including github.com/nats-io/nats-server/v2 and nats.
| Package | Affected | Fixed in |
|---|---|---|
github.com/nats-io/nats-server/v2 Go | From 2.11.0-RC.1 | 2.11.1 |
github.com/nats-io/nats-server/v2 Go | From 2.11.0-RC.1 | 2.11.1 |
github.com/nats-io/nats-server/v2 Go | From 2.2.0 | 2.10.27, 2.11.1 |
github.com/nats-io/nats-server/v2 Go | From 2.2.0 | 2.10.27 |
github.com/nats-io/nats-server/v2 Go | From 2.2.0 | 2.10.27 |
nats Bitnami | From 2.2.0 | 2.11.1 |
Linux distribution packages (1)
govulncheck-vulndb openSUSE:Tumbleweed | All versions | 0.0.20250422T152923-1.1 |
How do I fix CVE-2025-30215?
Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.1 or 2.10.27.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-30215 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30215 exists.
Sources
Also known as AZL-60399, AZL-60406, BIT-nats-2025-30215, CLEANSTART-2025-FI25096, CLEANSTART-2026-XD30138, DEBIAN-CVE-2025-30215 and 5 more.