{"answers":{"affected":"6 open source packages ship an affected version, including github.com/nats-io/nats-server/v2 and nats.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30215 exists.","fix":"Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.1 or 2.10.27.","what":"CVE-2025-30215 is a critical missing authorization vulnerability in nats-io nats-server, published on 15 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-30215 and fix it if it is affected.\n\nWhat it is: CVE-2025-30215 is a critical missing authorization vulnerability in nats-io nats-server, published on 15 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30215 exists.\n\nAffected packages and fixed versions:\n- github.com/nats-io/nats-server/v2 (Go): affected from 2.11.0-RC.1; fixed in 2.11.1\n- github.com/nats-io/nats-server/v2 (Go): affected from 2.11.0-RC.1; fixed in 2.11.1\n- github.com/nats-io/nats-server/v2 (Go): affected from 2.2.0; fixed in 2.10.27, 2.11.1\n- github.com/nats-io/nats-server/v2 (Go): affected from 2.2.0; fixed in 2.10.27\n- github.com/nats-io/nats-server/v2 (Go): affected from 2.2.0; fixed in 2.10.27\n- nats (Bitnami): affected from 2.2.0; fixed in 2.11.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-30215/ (Markdown: https://insights.sbomify.com/CVE-2025-30215/index.md)","id":"CVE-2025-30215","markdown":"https://insights.sbomify.com/CVE-2025-30215/index.md","name":"CVE-2025-30215","record":{"aliases":["AZL-60399","AZL-60406","BIT-nats-2025-30215","CLEANSTART-2025-FI25096","CLEANSTART-2026-XD30138","DEBIAN-CVE-2025-30215","GHSA-fhg8-qxh5-7q3w","GO-2025-3600","MGASA-2026-0232","UBUNTU-CVE-2025-30215","openSUSE-SU-2025:15014-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"NATS messaging server","requires_auth":"low_privilege","summary":"Attackers with JetStream management permissions can perform unauthorized administrative actions, including data destruction, on assets in other accounts.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-306","name":"Missing Authentication for Critical Functionality"},{"id":"CWE-287","name":"Improper Authentication"}],"description":"NATS-Server is a High-Performance server for NATS.io, the cloud and edge native messaging system. In versions starting from 2.2.0 but prior to 2.10.27 and 2.11.1, the management of JetStream assets happens with messages in the $JS. subject namespace in the system account; this is partially exposed into regular accounts to allow account holders to manage their assets. Some of the JS API requests were missing access controls, allowing any user with JS management permissions in any account to perform certain administrative actions on any JS asset in any other account. At least one of the unprotected APIs allows for data destruction. None of the affected APIs allow disclosing stream contents. This vulnerability is fixed in v2.11.1 or v2.10.27.","ecosystems":["Bitnami","Go","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"NATS-Server Fails to Authorize Certain Jetstream Admin APIs","id":"CVE-2025-30215","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":7,"n_references":2,"next":{"headline":"CryptoLib Has Heap Overflow in Crypto_TM_ProcessSecurity due to Unchecked Secondary Header Length","id":"CVE-2025-30216"},"packages":[{"ecosystem":"Bitnami","fixed":["2.11.1"],"introduced":["2.2.0"],"last_affected":[],"package":"nats","purl":"pkg:bitnami/nats","source":"BIT-nats-2025-30215"},{"ecosystem":"Go","fixed":["2.11.1"],"introduced":["2.11.0-RC.1"],"last_affected":[],"package":"github.com/nats-io/nats-server/v2","purl":null,"source":"GHSA-fhg8-qxh5-7q3w"},{"ecosystem":"Go","fixed":["2.11.1"],"introduced":["2.11.0-RC.1"],"last_affected":[],"package":"github.com/nats-io/nats-server/v2","purl":"pkg:golang/github.com/nats-io/nats-server/v2","source":"GHSA-fhg8-qxh5-7q3w"},{"ecosystem":"Go","fixed":["2.10.27","2.11.1"],"introduced":["2.2.0","2.11.0"],"last_affected":[],"package":"github.com/nats-io/nats-server/v2","purl":"pkg:golang/github.com/nats-io/nats-server/v2","source":"GO-2025-3600"},{"ecosystem":"Go","fixed":["2.10.27"],"introduced":["2.2.0"],"last_affected":[],"package":"github.com/nats-io/nats-server/v2","purl":null,"source":"GHSA-fhg8-qxh5-7q3w"},{"ecosystem":"Go","fixed":["2.10.27"],"introduced":["2.2.0"],"last_affected":[],"package":"github.com/nats-io/nats-server/v2","purl":"pkg:golang/github.com/nats-io/nats-server/v2","source":"GHSA-fhg8-qxh5-7q3w"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.0.20250422T152923-1.1"],"introduced":["0"],"last_affected":[],"package":"govulncheck-vulndb","purl":"pkg:rpm/opensuse/govulncheck-vulndb\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15014-1"}],"prev":{"headline":"Frappe vulnerable to information disclosure leading to account takeover","id":"CVE-2025-30214"},"products":["nats-server"],"published":"2025-04-15","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-17","vendors":["nats-io"]},"summary":"Attackers with JetStream management permissions can perform unauthorized administrative actions, including data destruction, on assets in other accounts.","url":"https://insights.sbomify.com/CVE-2025-30215/"}