# CVE-2025-30215: NATS-Server Fails to Authorize Certain Jetstream Admin APIs

> Attackers with JetStream management permissions can perform unauthorized administrative actions, including data destruction, on assets in other accounts.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2025
- **Updated:** 17 Apr 2025
- **Also known as:** AZL-60399, AZL-60406, BIT-nats-2025-30215, CLEANSTART-2025-FI25096, CLEANSTART-2026-XD30138, DEBIAN-CVE-2025-30215, GHSA-fhg8-qxh5-7q3w, GO-2025-3600, MGASA-2026-0232, UBUNTU-CVE-2025-30215, openSUSE-SU-2025:15014-1

## What is CVE-2025-30215?

CVE-2025-30215 is a critical missing authorization vulnerability in nats-io nats-server, published on 15 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NATS-Server is a High-Performance server for NATS.io, the cloud and edge native messaging system. In versions starting from 2.2.0 but prior to 2.10.27 and 2.11.1, the management of JetStream assets happens with messages in the $JS. subject namespace in the system account; this is partially exposed into regular accounts to allow account holders to manage their assets. Some of the JS API requests were missing access controls, allowing any user with JS management permissions in any account to perform certain administrative actions on any JS asset in any other account. At least one of the unprotected APIs allows for data destruction. None of the affected APIs allow disclosing stream contents. This vulnerability is fixed in v2.11.1 or v2.10.27.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-30215?

6 open source packages ship an affected version, including github.com/nats-io/nats-server/v2 and nats.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/nats-io/nats-server/v2` | Go | From 2.11.0-RC.1 | 2.11.1 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.11.0-RC.1 | 2.11.1 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.2.0 | 2.10.27, 2.11.1 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.2.0 | 2.10.27 |
| `github.com/nats-io/nats-server/v2` | Go | From 2.2.0 | 2.10.27 |
| `nats` | Bitnami | From 2.2.0 | 2.11.1 |
| `govulncheck-vulndb` | openSUSE:Tumbleweed | All versions | 0.0.20250422T152923-1.1 |

## How do I fix CVE-2025-30215?

Upgrade github.com/nats-io/nats-server/v2 to a fixed version for your release line: 2.11.1 or 2.10.27.

## Is CVE-2025-30215 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30215 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30215 and fix it if it is affected.

What it is: CVE-2025-30215 is a critical missing authorization vulnerability in nats-io nats-server, published on 15 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30215 exists.

Affected packages and fixed versions:
- github.com/nats-io/nats-server/v2 (Go): affected from 2.11.0-RC.1; fixed in 2.11.1
- github.com/nats-io/nats-server/v2 (Go): affected from 2.11.0-RC.1; fixed in 2.11.1
- github.com/nats-io/nats-server/v2 (Go): affected from 2.2.0; fixed in 2.10.27, 2.11.1
- github.com/nats-io/nats-server/v2 (Go): affected from 2.2.0; fixed in 2.10.27
- github.com/nats-io/nats-server/v2 (Go): affected from 2.2.0; fixed in 2.10.27
- nats (Bitnami): affected from 2.2.0; fixed in 2.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30215/ (Markdown: https://insights.sbomify.com/CVE-2025-30215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30215
- OSV: https://osv.dev/vulnerability/CVE-2025-30215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30215/
Summaries are generated and may contain mistakes; the official description above is the record.
