CVE-2025-30217 Frappe has possibility of SQL injection due to improper validations

Medium 6.6 Published Updated

A SQL injection vulnerability in the Frappe framework allows attackers to access sensitive information, requiring a patch update.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-30217?

CVE-2025-30217 is a medium-severity SQL injection vulnerability in frappe, published on 26 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Frappe is a full-stack web application framework. Prior to versions 14.93.2 and 15.55.0, a SQL Injection vulnerability has been identified in Frappe Framework which could allow a malicious actor to access sensitive information. Versions 14.93.2 and 15.55.0 contain a patch for the issue. No known workarounds are available.

Weakness: CWE-89

Which versions are affected by CVE-2025-30217?

5 open source packages ship an affected version, including frappe. It affects 1 product.

PackageAffectedFixed in
frappe PyPIAll versions14.93.2, 15.55.0
frappe PyPIAll versions14.93.2
frappe PyPIAll versions14.93.2
frappe PyPIFrom 15.0.015.55.0
frappe PyPIFrom 15.0.015.55.0

Products include Frappe Frappe.

How do I fix CVE-2025-30217?

Upgrade frappe to a fixed version for your release line: 14.93.2 or 15.55.0.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2025-30217 being exploited?

There is no known exploitation of CVE-2025-30217 in the wild and no public exploit code.

Sources

Also known as GHSA-6phg-4wmq-h5h3, PYSEC-2026-1391.

Is CVE-2025-30217 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free