# CVE-2025-30219: RabbitMQ has XSS Vulnerability in an Error Message in Management UI

> Attackers can execute arbitrary JavaScript in the RabbitMQ Management UI by manipulating virtual host names, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2025
- **Updated:** 26 Mar 2025
- **Also known as:** AZL-59276, AZL-59281, BIT-rabbitmq-2025-30219, DEBIAN-CVE-2025-30219, GHSA-g58g-82mw-9m3p, MINI-7vxj-r4gp-78v8, MINI-wvf2-96p7-75rg, SUSE-SU-2025:01466-1, SUSE-SU-2025:01548-1, SUSE-SU-2025:1466-1, SUSE-SU-2025:1548-1, SUSE-SU-2026:20126-1, UBUNTU-CVE-2025-30219, USN-7399-1, openSUSE-SU-2025:15291-1, openSUSE-SU-2026:20082-1

## What is CVE-2025-30219?

CVE-2025-30219 is a medium-severity cross-site scripting vulnerability in rabbitmq-server, published on 25 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

RabbitMQ is a messaging and streaming broker. Versions prior to 4.0.3 are vulnerable to a sophisticated attack that could modify virtual host name on disk and then make it unrecoverable (with other on disk file modifications) can lead to arbitrary JavaScript code execution in the browsers of management UI users. When a virtual host on a RabbitMQ node fails to start, recent versions
will display an error message (a notification) in the management UI. The error message includes virtual host name, which was not escaped prior to open source RabbitMQ 4.0.3 and Tanzu RabbitMQ 4.0.3, 3.13.8. An attack that both makes a virtual host fail to start and creates a new virtual host name with an XSS code snippet or changes the name of an existing virtual host on disk could trigger arbitrary JavaScript code execution in the management UI (the user's browser). Open source RabbitMQ `4.0.3` and Tanzu RabbitMQ `4.0.3` and `3.13.8` patch the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-30219?

1 open source package ship an affected version, including rabbitmq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | All versions | 4.0.3 |
| `rabbitmq-server` | SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 3.8.11-150300.3.19.1 |
| `rabbitmq-server313` | SUSE:Linux Enterprise Module for Server Applications 15 SP6 | All versions | 3.13.1-150600.13.8.1 |
| `rabbitmq-server` | SUSE:Linux Enterprise Module for Server Applications 15 SP7 | All versions | 3.8.11-150300.3.19.1 |
| `rabbitmq-server313` | SUSE:Linux Enterprise Module for Server Applications 15 SP7 | All versions | 3.13.1-150600.13.8.1 |
| `rabbitmq-server` | SUSE:Linux Enterprise Server 16.0 | All versions | 4.1.5-160000.1.1 |
| `rabbitmq-server` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 4.1.5-160000.1.1 |
| `rabbitmq-server` | openSUSE:Leap 15.6 | All versions | 3.8.11-150300.3.19.1 |
| `rabbitmq-server313` | openSUSE:Leap 15.6 | All versions | 3.13.1-150600.13.8.1 |
| `rabbitmq-server` | openSUSE:Leap 16.0 | All versions | 4.1.5-160000.1.1 |
| `rabbitmq-server` | openSUSE:Tumbleweed | All versions | 3.13.7-4.1 |

## How do I fix CVE-2025-30219?

Upgrade rabbitmq to 4.0.3 or later.

## Is CVE-2025-30219 being exploited?

There is no known exploitation of CVE-2025-30219 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30219 and fix it if it is affected.

What it is: CVE-2025-30219 is a medium-severity cross-site scripting vulnerability in rabbitmq-server, published on 25 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30219 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected all versions; fixed in 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30219/ (Markdown: https://insights.sbomify.com/CVE-2025-30219/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30219
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30219
- OSV: https://osv.dev/vulnerability/CVE-2025-30219

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30219/
Summaries are generated and may contain mistakes; the official description above is the record.
