# CVE-2025-30223: Beego allows Reflected/Stored XSS in Beego's RenderForm() Function Due to Unescaped User Input

> Attackers can inject malicious JavaScript via unescaped user input in Beego's RenderForm function, leading to session hijacking or credential theft.

- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2025
- **Updated:** 31 Mar 2025
- **Also known as:** CLEANSTART-2025-JI63720, CLEANSTART-2025-YL37771, GHSA-2j42-h78h-q4fg, GO-2025-3585, MINI-pg45-9rcf-f6jm

## What is CVE-2025-30223?

CVE-2025-30223 is a critical cross-site scripting vulnerability in beego, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Beego is an open-source web framework for the Go programming language. Prior to 2.3.6, a Cross-Site Scripting (XSS) vulnerability exists in Beego's RenderForm() function due to improper HTML escaping of user-controlled data. This vulnerability allows attackers to inject malicious JavaScript code that executes in victims' browsers, potentially leading to session hijacking, credential theft, or account takeover. The vulnerability affects any application using Beego's RenderForm() function with user-provided data. Since it is a high-level function generating an entire form markup, many developers would assume it automatically escapes attributes (the way most frameworks do). This vulnerability is fixed in 2.3.6.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-30223?

6 open source packages ship an affected version, including github.com/beego/beego and github.com/beego/beego/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/beego/beego` | Go | All versions | None |
| `github.com/beego/beego` | Go | All versions to 1.12.14 | None |
| `github.com/beego/beego` | Go | All versions to 1.12.14 | None |
| `github.com/beego/beego/v2` | Go | All versions | 2.3.6 |
| `github.com/beego/beego/v2` | Go | All versions | 2.3.6 |
| `github.com/beego/beego/v2` | Go | All versions | 2.3.6 |

Products: Beego Beego.

## How do I fix CVE-2025-30223?

Upgrade to a fixed version.

## Is CVE-2025-30223 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30223 exists.

## Other vulnerabilities in beego

- [CVE-2022-31836](https://insights.sbomify.com/CVE-2022-31836/): Path Traversal in Beego (critical 9.8)
- [CVE-2022-31259](https://insights.sbomify.com/CVE-2022-31259/): Access control bypass in beego (critical 9.8)
- [CVE-2021-30080](https://insights.sbomify.com/CVE-2021-30080/): Access control bypass in Beego (critical 9.8)
- [CVE-2024-40464](https://insights.sbomify.com/CVE-2024-40464/): Beego privilege escalation vulnerability (high 8.8)
- [CVE-2024-40465](https://insights.sbomify.com/CVE-2024-40465/): Beego privilege escalation vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30223 and fix it if it is affected.

What it is: CVE-2025-30223 is a critical cross-site scripting vulnerability in beego, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30223 exists.

Affected packages and fixed versions:
- github.com/beego/beego (Go): affected all versions; no fix listed
- github.com/beego/beego (Go): affected all versions up to 1.12.14; no fix listed
- github.com/beego/beego (Go): affected all versions up to 1.12.14; no fix listed
- github.com/beego/beego/v2 (Go): affected all versions; fixed in 2.3.6
- github.com/beego/beego/v2 (Go): affected all versions; fixed in 2.3.6
- github.com/beego/beego/v2 (Go): affected all versions; fixed in 2.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30223/ (Markdown: https://insights.sbomify.com/CVE-2025-30223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30223
- OSV: https://osv.dev/vulnerability/CVE-2025-30223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30223/
Summaries are generated and may contain mistakes; the official description above is the record.
