# CVE-2025-30225: Directus's S3 assets become unavailable after a burst of malformed transformations

> Attackers can cause all S3 assets to become unavailable by sending a burst of malformed transformation requests, affecting all user roles.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2025
- **Updated:** 26 Mar 2025
- **Also known as:** GHSA-j8xj-7jff-46mx

## What is CVE-2025-30225?

CVE-2025-30225 is a medium-severity denial of service vulnerability in Monospace Directus, published on 26 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. The `@directus/storage-driver-s3` package starting in version 9.22.0 and prior to version 12.0.1, corresponding to Directus starting in version 9.22.0 and prior to 11.5.0, is vulnerable to asset unavailability after a burst of malformed transformations. When making many malformed transformation requests at once, at some point, all assets are served as 403. This causes denial of assets for all policies of Directus, including Admin and Public. Version 12.0.1 of the `@directus/storage-driver-s3` package, corresponding to version 11.5.0 of Directus, fixes the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-30225?

4 open source packages ship an affected version, including @directus/storage-driver-s3 and directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@directus/storage-driver-s3` | npm | From 9.22.0 | 12.0.1 |
| `@directus/storage-driver-s3` | npm | From 9.22.0 | 12.0.1 |
| `directus` | npm | From 9.22.0 | 11.5.0 |
| `directus` | npm | From 9.22.0 | 11.5.0 |

Products: Monospace Directus.

## How do I fix CVE-2025-30225?

Upgrade @directus/storage-driver-s3 to 12.0.1 or later.

## Is CVE-2025-30225 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30225 exists.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30225 and fix it if it is affected.

What it is: CVE-2025-30225 is a medium-severity denial of service vulnerability in Monospace Directus, published on 26 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30225 exists.

Affected packages and fixed versions:
- @directus/storage-driver-s3 (npm): affected from 9.22.0; fixed in 12.0.1
- @directus/storage-driver-s3 (npm): affected from 9.22.0; fixed in 12.0.1
- directus (npm): affected from 9.22.0; fixed in 11.5.0
- directus (npm): affected from 9.22.0; fixed in 11.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30225/ (Markdown: https://insights.sbomify.com/CVE-2025-30225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30225
- OSV: https://osv.dev/vulnerability/CVE-2025-30225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30225/
Summaries are generated and may contain mistakes; the official description above is the record.
