# CVE-2025-30351: Suspended Directus user can continue to use session token to access API

> Suspended Directus users can retain API access using existing session tokens due to missing status verification, allowing unauthorized data access.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Mar 2025
- **Updated:** 9 Jun 2025
- **Also known as:** GHSA-56p6-qw3c-fq2g

## What is CVE-2025-30351?

CVE-2025-30351 is a low-severity authentication bypass vulnerability in Monospace Directus, published on 26 Mar 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. Starting in version 10.10.0 and prior to version 11.5.0, a suspended user can use the token generated in session auth mode to access the API despite their status. This happens because there is a check missing in `verifySessionJWT` to verify that a user is actually still active and allowed to access the API. One can extract the session token obtained by, e.g. login in to the app while still active and then, after the user has been suspended continue to use that token until it expires. Version 11.5.0 patches the issue.

Weakness: CWE-672 (Operation on a Resource after Expiration or Release)

## Which versions are affected by CVE-2025-30351?

6 open source packages ship an affected version, including @directus/api, @directus/types and directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@directus/api` | npm | From 18.0.0 | 24.0.1 |
| `@directus/api` | npm | From 18.0.0 | 24.0.1 |
| `@directus/types` | npm | From 11.0.7 | 13.0.0 |
| `@directus/types` | npm | From 11.0.7 | 13.0.0 |
| `directus` | npm | From 10.10.0 | 11.5.0 |
| `directus` | npm | From 10.10.0 | 11.5.0 |

Products: Monospace Directus.

## How do I fix CVE-2025-30351?

Upgrade @directus/api to 24.0.1 or later.

## Is CVE-2025-30351 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30351 exists.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30351 and fix it if it is affected.

What it is: CVE-2025-30351 is a low-severity authentication bypass vulnerability in Monospace Directus, published on 26 Mar 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30351 exists.

Affected packages and fixed versions:
- @directus/api (npm): affected from 18.0.0; fixed in 24.0.1
- @directus/api (npm): affected from 18.0.0; fixed in 24.0.1
- @directus/types (npm): affected from 11.0.7; fixed in 13.0.0
- @directus/types (npm): affected from 11.0.7; fixed in 13.0.0
- directus (npm): affected from 10.10.0; fixed in 11.5.0
- directus (npm): affected from 10.10.0; fixed in 11.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30351/ (Markdown: https://insights.sbomify.com/CVE-2025-30351/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30351
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30351
- OSV: https://osv.dev/vulnerability/CVE-2025-30351

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30351/
Summaries are generated and may contain mistakes; the official description above is the record.
