# CVE-2025-30352: Directus `search` query parameter allows enumeration of non permitted fields

> Attackers can enumerate contents of fields they lack permission to view by exploiting the search query parameter in Directus.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2025
- **Updated:** 27 Mar 2025
- **Also known as:** GHSA-7wq3-jr35-275c

## What is CVE-2025-30352?

CVE-2025-30352 is a medium-severity vulnerability in Monospace Directus, published on 26 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directus is a real-time API and App dashboard for managing SQL database content. Starting in version 9.0.0-alpha.4 and prior to version 11.5.0, the `search` query parameter allows users with access to a collection to filter items based on fields they do not have permission to view. This allows the enumeration of unknown field contents. The searchable columns (numbers & strings) are not checked against permissions when injecting the `where` clauses for applying the search query. This leads to the possibility of enumerating those un-permitted fields. Version 11.5.0 fixes the issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-30352?

2 open source packages ship an affected version, including directus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `directus` | npm | From 9.0.0-alpha.4 | 11.5.0 |
| `directus` | npm | From 9.0.0-alpha.4 | 11.5.0 |

Products: Monospace Directus.

## How do I fix CVE-2025-30352?

Upgrade directus to 11.5.0 or later.

## Is CVE-2025-30352 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30352 exists.

## Other vulnerabilities in Monospace Directus

- [CVE-2022-26969](https://insights.sbomify.com/CVE-2022-26969/): Insecure default value for CORS configuration (critical 9.8)
- [CVE-2025-55746](https://insights.sbomify.com/CVE-2025-55746/): Directus allows unauthenticated file upload and file modification due to lacking input sanitization (critical 9.3)
- [CVE-2026-35408](https://insights.sbomify.com/CVE-2026-35408/): Directus is Missing Cross-Origin Opener Policy (high 8.7)
- [CVE-2026-61836](https://insights.sbomify.com/CVE-2026-61836/): Directus: Authorization-dependent response served from unsegmented cache key (high 8.6)
- [CVE-2025-30353](https://insights.sbomify.com/CVE-2025-30353/): Directus's webhook trigger flows can leak sensitive data (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30352 and fix it if it is affected.

What it is: CVE-2025-30352 is a medium-severity vulnerability in Monospace Directus, published on 26 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30352 exists.

Affected packages and fixed versions:
- directus (npm): affected from 9.0.0-alpha.4; fixed in 11.5.0
- directus (npm): affected from 9.0.0-alpha.4; fixed in 11.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30352/ (Markdown: https://insights.sbomify.com/CVE-2025-30352/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30352
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30352
- OSV: https://osv.dev/vulnerability/CVE-2025-30352

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30352/
Summaries are generated and may contain mistakes; the official description above is the record.
