CVE-2025-30355 Synapse vulnerable to federation denial of service via malformed events

High 7.1 Published Updated

A malicious server can cause Synapse to stop federating with other servers by sending malformed events, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-30355?

CVE-2025-30355 is a high-severity denial of service vulnerability in element-hq synapse, published on 27 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Synapse is an open source Matrix homeserver implementation. A malicious server can craft events which, when received, prevent Synapse version up to 1.127.0 from federating with other servers. The vulnerability has been exploited in the wild and has been fixed in Synapse v1.127.1. No known workarounds are available.

Weakness: CWE-20

Which versions are affected by CVE-2025-30355?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.

PackageAffectedFixed in
matrix-synapse PyPIAll versions1.127.1
matrix-synapse PyPIAll versions1.127.1
matrix-synapse PyPIAll versions1.127.1
Linux distribution packages (1)
matrix-synapse openSUSE:TumbleweedAll versions1.127.1-1.1

Products include Matrix Synapse.

How do I fix CVE-2025-30355?

Upgrade matrix-synapse to 1.127.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-30355 being exploited?

There is no known exploitation of CVE-2025-30355 in the wild and no public exploit code.

Sources

Also known as GHSA-v56r-hwv5-mxg6, PYSEC-2026-1614, UBUNTU-CVE-2025-30355, openSUSE-SU-2025:14939-1.

Is CVE-2025-30355 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free