{"answers":{"affected":"3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-30355 in the wild and no public exploit code.","fix":"Upgrade matrix-synapse to 1.127.1 or later.","what":"CVE-2025-30355 is a high-severity denial of service vulnerability in element-hq synapse, published on 27 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-30355 and fix it if it is affected.\n\nWhat it is: CVE-2025-30355 is a high-severity denial of service vulnerability in element-hq synapse, published on 27 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-30355 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- matrix-synapse (PyPI): affected all versions; fixed in 1.127.1\n- matrix-synapse (PyPI): affected all versions; fixed in 1.127.1\n- matrix-synapse (PyPI): affected all versions; fixed in 1.127.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-30355/ (Markdown: https://insights.sbomify.com/CVE-2025-30355/index.md)","id":"CVE-2025-30355","markdown":"https://insights.sbomify.com/CVE-2025-30355/index.md","name":"CVE-2025-30355","record":{"aliases":["GHSA-v56r-hwv5-mxg6","PYSEC-2026-1614","UBUNTU-CVE-2025-30355","openSUSE-SU-2025:14939-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Matrix homeserver","requires_auth":"low_privilege","summary":"A malicious server can cause Synapse to stop federating with other servers by sending malformed events, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"synapse","vendor":"matrix"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Synapse is an open source Matrix homeserver implementation. A malicious server can craft events which, when received, prevent Synapse version up to 1.127.0 from federating with other servers. The vulnerability has been exploited in the wild and has been fixed in Synapse v1.127.1. No known workarounds are available.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Synapse vulnerable to federation denial of service via malformed events","id":"CVE-2025-30355","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"Heap Buffer Overflow via Incomplete Length Check in `Crypto_TC_ApplySecurity`","id":"CVE-2025-30356"},"packages":[{"ecosystem":"PyPI","fixed":["1.127.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":null,"source":"GHSA-v56r-hwv5-mxg6"},{"ecosystem":"PyPI","fixed":["1.127.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:pypi/matrix-synapse","source":"GHSA-v56r-hwv5-mxg6"},{"ecosystem":"PyPI","fixed":["1.127.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:pypi/matrix-synapse","source":"PYSEC-2026-1614"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.127.1-1.1"],"introduced":["0"],"last_affected":[],"package":"matrix-synapse","purl":"pkg:rpm/opensuse/matrix-synapse\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:14939-1"}],"prev":{"headline":"Bruno ignores Safe-Mode in Asserts expressions","id":"CVE-2025-30354"},"products":["synapse"],"published":"2025-03-27","related":[{"cvss_score":9.8,"headline":"Improper Verification of Cryptographic Signature in matrix-synapse","id":"CVE-2019-18835","kev_date_added":null,"published":"2019-11-07"},{"cvss_score":8.7,"headline":"Synapse allows a a malformed invite to break the invitee's `/sync`","id":"CVE-2024-52815","kev_date_added":null,"published":"2024-12-03"},{"cvss_score":8.2,"headline":"Synapse allows unsupported content types to lead to memory exhaustion","id":"CVE-2024-52805","kev_date_added":null,"published":"2024-12-03"},{"cvss_score":8.2,"headline":"Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders","id":"CVE-2024-53863","kev_date_added":null,"published":"2024-12-03"},{"cvss_score":7.5,"headline":"Synapse denial of service through media disk space consumption","id":"CVE-2024-37302","kev_date_added":null,"published":"2024-12-03"},{"cvss_score":7.5,"headline":"Matrix Synapse Authorization Error","id":"CVE-2018-12423","kev_date_added":null,"published":"2018-06-14"},{"cvss_score":7.5,"headline":"Matrix Synapse Security Filtering Flaw","id":"CVE-2018-12291","kev_date_added":null,"published":"2018-06-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-27","vendors":["element-hq"]},"summary":"A malicious server can cause Synapse to stop federating with other servers by sending malformed events, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2025-30355/"}