# CVE-2025-30355: Synapse vulnerable to federation denial of service via malformed events

> A malicious server can cause Synapse to stop federating with other servers by sending malformed events, requiring an upgrade to fix.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2025
- **Updated:** 27 Mar 2025
- **Also known as:** GHSA-v56r-hwv5-mxg6, PYSEC-2026-1614, UBUNTU-CVE-2025-30355, openSUSE-SU-2025:14939-1

## What is CVE-2025-30355?

CVE-2025-30355 is a high-severity denial of service vulnerability in element-hq synapse, published on 27 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Synapse is an open source Matrix homeserver implementation. A malicious server can craft events which, when received, prevent Synapse version up to 1.127.0 from federating with other servers. The vulnerability has been exploited in the wild and has been fixed in Synapse v1.127.1. No known workarounds are available.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-30355?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.127.1 |
| `matrix-synapse` | PyPI | All versions | 1.127.1 |
| `matrix-synapse` | PyPI | All versions | 1.127.1 |
| `matrix-synapse` | openSUSE:Tumbleweed | All versions | 1.127.1-1.1 |

Products: Matrix Synapse.

## How do I fix CVE-2025-30355?

Upgrade matrix-synapse to 1.127.1 or later.

## Is CVE-2025-30355 being exploited?

There is no known exploitation of CVE-2025-30355 in the wild and no public exploit code.

## Other vulnerabilities in element-hq synapse

- [CVE-2019-18835](https://insights.sbomify.com/CVE-2019-18835/): Improper Verification of Cryptographic Signature in matrix-synapse (critical 9.8)
- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-52805](https://insights.sbomify.com/CVE-2024-52805/): Synapse allows unsupported content types to lead to memory exhaustion (high 8.2)
- [CVE-2024-53863](https://insights.sbomify.com/CVE-2024-53863/): Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders (high 8.2)
- [CVE-2024-37302](https://insights.sbomify.com/CVE-2024-37302/): Synapse denial of service through media disk space consumption (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30355 and fix it if it is affected.

What it is: CVE-2025-30355 is a high-severity denial of service vulnerability in element-hq synapse, published on 27 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30355 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.127.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.127.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.127.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30355/ (Markdown: https://insights.sbomify.com/CVE-2025-30355/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30355
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30355
- OSV: https://osv.dev/vulnerability/CVE-2025-30355

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30355/
Summaries are generated and may contain mistakes; the official description above is the record.
