# CVE-2025-30358: Mesop Class Pollution vulnerability leads to DoS and Jailbreak attacks

> Attackers can pollute classes to cause denial of service, impersonate roles, or potentially execute code in Mesop applications.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2025
- **Updated:** 27 Mar 2025
- **Also known as:** GHSA-f3mf-hm6v-jfhh, PYSEC-2026-1624

## What is CVE-2025-30358?

CVE-2025-30358 is a high-severity code injection vulnerability in mesop-dev mesop, published on 27 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mesop is a Python-based UI framework that allows users to build web applications. A class pollution vulnerability in Mesop prior to version 0.14.1 allows attackers to overwrite global variables and class attributes in certain Mesop modules during runtime. This vulnerability could directly lead to a denial of service (DoS) attack against the server. Additionally, it could also result in other severe consequences given the application's implementation, such as identity confusion, where an attacker could impersonate an assistant or system role within conversations. This impersonation could potentially enable jailbreak attacks when interacting with large language models (LLMs). Just like the Javascript's prototype pollution, this vulnerability could leave a way for attackers to manipulate the intended data-flow or control-flow of the application at runtime and lead to severe consequences like remote code execution when gadgets are available. Users should upgrade to version 0.14.1 to obtain a fix for the issue.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2025-30358?

3 open source packages ship an affected version, including mesop.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mesop` | PyPI | All versions | 0.14.1 |
| `mesop` | PyPI | All versions | 0.14.1 |
| `mesop` | PyPI | All versions | 0.14.1 |

## How do I fix CVE-2025-30358?

Upgrade mesop to 0.14.1 or later.

## Is CVE-2025-30358 being exploited?

There is no known exploitation of CVE-2025-30358 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30358 and fix it if it is affected.

What it is: CVE-2025-30358 is a high-severity code injection vulnerability in mesop-dev mesop, published on 27 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30358 in the wild and no public exploit code.

Affected packages and fixed versions:
- mesop (PyPI): affected all versions; fixed in 0.14.1
- mesop (PyPI): affected all versions; fixed in 0.14.1
- mesop (PyPI): affected all versions; fixed in 0.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30358/ (Markdown: https://insights.sbomify.com/CVE-2025-30358/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30358
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30358
- OSV: https://osv.dev/vulnerability/CVE-2025-30358

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30358/
Summaries are generated and may contain mistakes; the official description above is the record.
