# CVE-2025-30370: jupyterlab-git has a command injection vulnerability in "Open Git Repository in Terminal"

> Attackers can execute arbitrary shell commands by tricking users into opening a maliciously named Git repository in the terminal via the JupyterLab Git extension.

- **Severity:** High 7.4 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Apr 2025
- **Updated:** 4 Apr 2025
- **Also known as:** GHSA-cj5w-8mjf-r5f8, PYSEC-2026-1483

## What is CVE-2025-30370?

CVE-2025-30370 is a high-severity command injection vulnerability in jupyterlab-git, published on 3 Apr 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

jupyterlab-git is a JupyterLab extension for version control using Git. On many platforms, a third party can create a Git repository under a name that includes a shell command substitution string in the syntax $(<command>). These directory names are allowed in macOS and a majority of Linux distributions. If a user starts jupyter-lab in a parent directory of this inappropriately-named Git repository, opens it, and clicks "Git > Open Git Repository in Terminal" from the menu bar, then the injected command <command> is run in the user's shell without the user's permission. This issue is occurring because when that menu entry is clicked, jupyterlab-git opens the terminal and runs cd <git-repo-path> through the shell to set the current directory. Doing so runs any command substitution strings present in the directory name, which leads to the command injection issue described here. A previous patch provided an incomplete fix. This vulnerability is fixed in 0.51.1.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-30370?

3 open source packages ship an affected version, including jupyterlab-git.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyterlab-git` | PyPI | All versions | 0.51.1 |
| `jupyterlab-git` | PyPI | All versions | 0.51.1 |
| `jupyterlab-git` | PyPI | All versions | 0.51.1 |

## How do I fix CVE-2025-30370?

Upgrade jupyterlab-git to 0.51.1 or later.

## Is CVE-2025-30370 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30370 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30370 and fix it if it is affected.

What it is: CVE-2025-30370 is a high-severity command injection vulnerability in jupyterlab-git, published on 3 Apr 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-30370 exists.

Affected packages and fixed versions:
- jupyterlab-git (PyPI): affected all versions; fixed in 0.51.1
- jupyterlab-git (PyPI): affected all versions; fixed in 0.51.1
- jupyterlab-git (PyPI): affected all versions; fixed in 0.51.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30370/ (Markdown: https://insights.sbomify.com/CVE-2025-30370/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30370
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30370
- OSV: https://osv.dev/vulnerability/CVE-2025-30370

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30370/
Summaries are generated and may contain mistakes; the official description above is the record.
