# CVE-2025-30371: Metabase vulnerable to circumvention of local link access protection in GeoJson endpoint

> Attackers can bypass local link protections in the GeoJson endpoint to access internal resources, impacting self-hosted Metabase instances.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Mar 2025
- **Updated:** 28 Mar 2025
- **Also known as:** GHSA-8xf9-9jc8-qp98

## What is CVE-2025-30371?

CVE-2025-30371 is a low-severity server-side request forgery vulnerability in metabase, published on 28 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Metabase is a business intelligence and embedded analytics tool. Versions prior to v0.52.16.4, v1.52.16.4, v0.53.8, and v1.53.8 are vulnerable to circumvention of local link access protection in GeoJson endpoint. Self hosted Metabase instances that are using the GeoJson feature could be potentially impacted if their Metabase is colocated with other unsecured resources. This is fixed in v0.52.16.4, v1.52.16.4, v0.53.8, and v1.53.8. Migrating to Metabase Cloud or redeploying Metabase in a dedicated subnet with strict outbound port controls is an available workaround.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2025-30371?


## How do I fix CVE-2025-30371?

No fix has been published for CVE-2025-30371 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-30371 being exploited?

There is no known exploitation of CVE-2025-30371 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30371 and fix it if it is affected.

What it is: CVE-2025-30371 is a low-severity server-side request forgery vulnerability in metabase, published on 28 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30371 in the wild and no public exploit code.

Affected product: metabase. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30371/ (Markdown: https://insights.sbomify.com/CVE-2025-30371/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30371
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30371
- OSV: https://osv.dev/vulnerability/CVE-2025-30371

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30371/
Summaries are generated and may contain mistakes; the official description above is the record.
