CVE-2025-30373 Graylog Authenticated HTTP inputs do ingest message even if Authorization header is missing or has wrong value
Authenticated HTTP inputs in Graylog ingest messages despite missing or invalid Authorization headers, allowing unauthorized data injection.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-30373?
CVE-2025-30373 is a medium-severity authentication bypass vulnerability in graylog2-server, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Graylog is a free and open log management platform. Starting with 6.1, HTTP Inputs can be configured to check if a specified header is present and has a specified value to authenticate HTTP-based ingestion. Unfortunately, even though in cases of a missing header or a wrong value the correct HTTP response (401) is returned, the message will be ingested nonetheless. To mitigate the vulnerability, disable http-based inputs and allow only authenticated pull-based inputs. This vulnerability is fixed in 6.1.9.
Weakness: CWE-285
Which versions are affected by CVE-2025-30373?
2 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.graylog2:graylog2-server Maven | From 6.1.0 | 6.1.9 |
org.graylog2:graylog2-server Maven | From 6.1.0 | 6.1.9 |
Products include Graylog Graylog.
How do I fix CVE-2025-30373?
Upgrade org.graylog2:graylog2-server to 6.1.9 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-30373 being exploited?
There is no known exploitation of CVE-2025-30373 in the wild and no public exploit code.
Other vulnerabilities in graylog2-server
- CVE-2021-37759 Information disclosure in n/a
- CVE-2021-37760 Information disclosure in n/a
- CVE-2026-1435 Incorrect management of session invalidation vulnerability in Graylog Web Interface
- CVE-2025-53106 Graylog vulnerable to privilege escalation through API tokens
- CVE-2024-24824 graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request
Sources
Also known as GHSA-q7g5-jq6p-6wvx.