# CVE-2025-30373: Graylog Authenticated HTTP inputs do ingest message even if Authorization header is missing or has wrong value

> Authenticated HTTP inputs in Graylog ingest messages despite missing or invalid Authorization headers, allowing unauthorized data injection.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2025
- **Updated:** 8 Apr 2025
- **Also known as:** GHSA-q7g5-jq6p-6wvx

## What is CVE-2025-30373?

CVE-2025-30373 is a medium-severity authentication bypass vulnerability in graylog2-server, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Graylog is a free and open log management platform. Starting with 6.1, HTTP Inputs can be configured to check if a specified header is present and has a specified value to authenticate HTTP-based ingestion. Unfortunately, even though in cases of a missing header or a wrong value the correct HTTP response (401) is returned, the message will be ingested nonetheless. To mitigate the vulnerability, disable http-based inputs and allow only authenticated pull-based inputs. This vulnerability is fixed in 6.1.9.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-30373?

2 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.graylog2:graylog2-server` | Maven | From 6.1.0 | 6.1.9 |
| `org.graylog2:graylog2-server` | Maven | From 6.1.0 | 6.1.9 |

Products: Graylog Graylog.

## How do I fix CVE-2025-30373?

Upgrade org.graylog2:graylog2-server to 6.1.9 or later.

## Is CVE-2025-30373 being exploited?

There is no known exploitation of CVE-2025-30373 in the wild and no public exploit code.

## Other vulnerabilities in graylog2-server

- [CVE-2021-37759](https://insights.sbomify.com/CVE-2021-37759/): Information disclosure in n/a (critical 9.8)
- [CVE-2021-37760](https://insights.sbomify.com/CVE-2021-37760/): Information disclosure in n/a (critical 9.8)
- [CVE-2026-1435](https://insights.sbomify.com/CVE-2026-1435/): Incorrect management of session invalidation vulnerability in Graylog Web Interface (critical 9.3)
- [CVE-2025-53106](https://insights.sbomify.com/CVE-2025-53106/): Graylog vulnerable to privilege escalation through API tokens (high 8.8)
- [CVE-2024-24824](https://insights.sbomify.com/CVE-2024-24824/): graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30373 and fix it if it is affected.

What it is: CVE-2025-30373 is a medium-severity authentication bypass vulnerability in graylog2-server, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30373 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.graylog2:graylog2-server (Maven): affected from 6.1.0; fixed in 6.1.9
- org.graylog2:graylog2-server (Maven): affected from 6.1.0; fixed in 6.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30373/ (Markdown: https://insights.sbomify.com/CVE-2025-30373/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30373
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30373
- OSV: https://osv.dev/vulnerability/CVE-2025-30373

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30373/
Summaries are generated and may contain mistakes; the official description above is the record.
