# CVE-2025-30402: ExecuTorch vulnerable to Heap-based Buffer Overflow attack

> Heap-buffer-overflow in ExecuTorch method loading allows attackers to crash the runtime or potentially execute arbitrary code.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Jul 2025
- **Updated:** 11 Jul 2025
- **Also known as:** GHSA-h952-963h-rv99, PYSEC-2026-1352

## What is CVE-2025-30402?

CVE-2025-30402 is a high-severity memory corruption vulnerability in Meta Platforms, Inc ExecuTorch, published on 11 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A heap-buffer-overflow vulnerability in the loading of ExecuTorch methods can cause the runtime to crash and potentially result in code execution or other undesirable effects. This issue affects ExecuTorch prior to commit 93b1a0c15f7eda49b2bc46b5b4c49557b4e9810f

## Which versions are affected by CVE-2025-30402?

7 open source packages ship an affected version, including executorch, org.pytorch:executorch-android and github.com/pytorch/executorch.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `executorch` | PyPI | All versions | 0.7.0 |
| `executorch` | PyPI | All versions | 0.7.0 |
| `executorch` | PyPI | All versions | 0.7.0 |
| `org.pytorch:executorch-android` | Maven | All versions | 0.7.0-rc1 |
| `org.pytorch:executorch-android` | Maven | All versions | 0.7.0-rc1 |
| `github.com/pytorch/executorch` | SwiftURL | All versions | 0.7.0-rc1 |
| `github.com/pytorch/executorch` | SwiftURL | All versions | 0.7.0-rc1 |

## How do I fix CVE-2025-30402?

Upgrade executorch to 0.7.0 or later.

## Is CVE-2025-30402 being exploited?

There is no known exploitation of CVE-2025-30402 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30402 and fix it if it is affected.

What it is: CVE-2025-30402 is a high-severity memory corruption vulnerability in Meta Platforms, Inc ExecuTorch, published on 11 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-30402 in the wild and no public exploit code.

Affected packages and fixed versions:
- executorch (PyPI): affected all versions; fixed in 0.7.0
- executorch (PyPI): affected all versions; fixed in 0.7.0
- executorch (PyPI): affected all versions; fixed in 0.7.0
- org.pytorch:executorch-android (Maven): affected all versions; fixed in 0.7.0-rc1
- org.pytorch:executorch-android (Maven): affected all versions; fixed in 0.7.0-rc1
- github.com/pytorch/executorch (SwiftURL): affected all versions; fixed in 0.7.0-rc1
- github.com/pytorch/executorch (SwiftURL): affected all versions; fixed in 0.7.0-rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30402/ (Markdown: https://insights.sbomify.com/CVE-2025-30402/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30402
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30402
- OSV: https://osv.dev/vulnerability/CVE-2025-30402

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30402/
Summaries are generated and may contain mistakes; the official description above is the record.
