CVE-2025-3044 MD5 Hash Collision in run-llama/llama_index
Attackers can cause data loss by exploiting MD5 hash collisions in ArxivReader, leading to overwritten files during paper downloads.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-3044?
CVE-2025-3044 is a medium-severity vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A vulnerability in the ArxivReader class of the run-llama/llama_index repository, versions up to v0.12.22.post1, allows for MD5 hash collisions when generating filenames for downloaded papers. This can lead to data loss as papers with identical titles but different contents may overwrite each other, preventing some papers from being processed for AI model training. The issue is resolved in version 0.12.28.
Weakness: CWE-440
Which versions are affected by CVE-2025-3044?
4 open source packages ship an affected version, including llama-index-readers-papers and llama-index. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
llama-index-readers-papers PyPI | All versions | 0.3.1 |
llama-index-readers-papers PyPI | All versions | 0.3.1 |
llama-index-readers-papers PyPI | All versions | 0.3.1 |
llama-index PyPI | All versions | 0.12.28 |
Products include Llamaindex Llamaindex.
How do I fix CVE-2025-3044?
Upgrade llama-index-readers-papers to 0.3.1 or later.
Is CVE-2025-3044 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3044 exists.
Other vulnerabilities in run-llama/llama_index
Sources
Also known as GHSA-p7j4-jwjf-5x9w, PYSEC-2025-247, PYSEC-2026-1569.