# CVE-2025-3044: MD5 Hash Collision in run-llama/llama_index

> Attackers can cause data loss by exploiting MD5 hash collisions in ArxivReader, leading to overwritten files during paper downloads.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2025
- **Updated:** 7 Jul 2025
- **Also known as:** GHSA-p7j4-jwjf-5x9w, PYSEC-2025-247, PYSEC-2026-1569

## What is CVE-2025-3044?

CVE-2025-3044 is a medium-severity vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the ArxivReader class of the run-llama/llama_index repository, versions up to v0.12.22.post1, allows for MD5 hash collisions when generating filenames for downloaded papers. This can lead to data loss as papers with identical titles but different contents may overwrite each other, preventing some papers from being processed for AI model training. The issue is resolved in version 0.12.28.

Weakness: CWE-440 (Expected Behavior Violation)

## Which versions are affected by CVE-2025-3044?

4 open source packages ship an affected version, including llama-index-readers-papers and llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-readers-papers` | PyPI | All versions | 0.3.1 |
| `llama-index-readers-papers` | PyPI | All versions | 0.3.1 |
| `llama-index-readers-papers` | PyPI | All versions | 0.3.1 |
| `llama-index` | PyPI | All versions | 0.12.28 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2025-3044?

Upgrade llama-index-readers-papers to 0.3.1 or later.

## Is CVE-2025-3044 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3044 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3044 and fix it if it is affected.

What it is: CVE-2025-3044 is a medium-severity vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3044 exists.

Affected packages and fixed versions:
- llama-index-readers-papers (PyPI): affected all versions; fixed in 0.3.1
- llama-index-readers-papers (PyPI): affected all versions; fixed in 0.3.1
- llama-index-readers-papers (PyPI): affected all versions; fixed in 0.3.1
- llama-index (PyPI): affected all versions; fixed in 0.12.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3044/ (Markdown: https://insights.sbomify.com/CVE-2025-3044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3044
- OSV: https://osv.dev/vulnerability/CVE-2025-3044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3044/
Summaries are generated and may contain mistakes; the official description above is the record.
