# CVE-2025-3046: Path Traversal via Symbolic Links in run-llama/llama_index

> Attackers can read arbitrary files outside the intended directory by exploiting symbolic link handling in the ObsidianReader class of the llama_index library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2025
- **Updated:** 7 Jul 2025
- **Also known as:** GHSA-fmrf-6jv9-qjc7, PYSEC-2025-248, PYSEC-2026-1568

## What is CVE-2025-3046?

CVE-2025-3046 is a high-severity path traversal vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the `ObsidianReader` class of the run-llama/llama_index repository, versions 0.12.23 to 0.12.28, allows for arbitrary file read through symbolic links. The `ObsidianReader` fails to resolve symlinks to their real paths and does not validate whether the resolved paths lie within the intended directory. This flaw enables attackers to place symlinks pointing to files outside the vault directory, which are then processed as valid Markdown files, potentially exposing sensitive information.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-3046?

4 open source packages ship an affected version, including llama-index-readers-obsidian and llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-readers-obsidian` | PyPI | All versions | 0.5.1 |
| `llama-index-readers-obsidian` | PyPI | All versions | 0.5.1 |
| `llama-index-readers-obsidian` | PyPI | All versions | 0.5.1 |
| `llama-index` | PyPI | From 0.12.23 | 0.12.28 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2025-3046?

Upgrade llama-index-readers-obsidian to 0.5.1 or later.

## Is CVE-2025-3046 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3046 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3046 and fix it if it is affected.

What it is: CVE-2025-3046 is a high-severity path traversal vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3046 exists.

Affected packages and fixed versions:
- llama-index-readers-obsidian (PyPI): affected all versions; fixed in 0.5.1
- llama-index-readers-obsidian (PyPI): affected all versions; fixed in 0.5.1
- llama-index-readers-obsidian (PyPI): affected all versions; fixed in 0.5.1
- llama-index (PyPI): affected from 0.12.23; fixed in 0.12.28

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3046/ (Markdown: https://insights.sbomify.com/CVE-2025-3046/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3046
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3046
- OSV: https://osv.dev/vulnerability/CVE-2025-3046

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3046/
Summaries are generated and may contain mistakes; the official description above is the record.
