# CVE-2025-3047: Path Traversal in AWS SAM CLI allows file copy to build container


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 31 Mar 2025
- **Updated:** 14 Oct 2025
- **Also known as:** GHSA-px37-jpqx-97q9, PYSEC-2026-1207

## What is CVE-2025-3047?

CVE-2025-3047 is a medium-severity vulnerability in AWS Serverless Application Model Command Line Interface, published on 31 Mar 2025. 

### Official description

When running the AWS Serverless Application Model Command Line Interface (SAM CLI) build process with Docker and symlinks are included in the build files, the container environment allows a user to access privileged files on the host by leveraging the elevated permissions granted to the tool. A user could leverage the elevated permissions to access restricted files via symlinks and copy them to a more permissive location on the container. 

Users should upgrade to v1.133.0 or newer and ensure any forked or derivative code is patched to incorporate the new fixes.

Weakness: CWE-61 (UNIX Symbolic Link (Symlink) Following)

## Which versions are affected by CVE-2025-3047?

3 open source packages ship an affected version, including aws-sam-cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aws-sam-cli` | PyPI | All versions | 1.133.0 |
| `aws-sam-cli` | PyPI | All versions | 1.133.0 |
| `aws-sam-cli` | PyPI | All versions | 1.133.0 |

## How do I fix CVE-2025-3047?

Upgrade aws-sam-cli to 1.133.0 or later.

## Is CVE-2025-3047 being exploited?

There is no known exploitation of CVE-2025-3047 in the wild and no public exploit code.

Public exploit code:

- Issue with AWS SAM CLI (CVE-2025-3047, CVE-2025-3048) (github_poc): https://github.com/murataydemir/AWS-SAM-CLI-Vulnerabilities

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3047 and fix it if it is affected.

What it is: CVE-2025-3047 is a medium-severity vulnerability in AWS Serverless Application Model Command Line Interface, published on 31 Mar 2025. 
Exploitation: There is no known exploitation of CVE-2025-3047 in the wild and no public exploit code.

Affected packages and fixed versions:
- aws-sam-cli (PyPI): affected all versions; fixed in 1.133.0
- aws-sam-cli (PyPI): affected all versions; fixed in 1.133.0
- aws-sam-cli (PyPI): affected all versions; fixed in 1.133.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3047/ (Markdown: https://insights.sbomify.com/CVE-2025-3047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3047
- OSV: https://osv.dev/vulnerability/CVE-2025-3047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3047/
Summaries are generated and may contain mistakes; the official description above is the record.
