# CVE-2025-30473: Apache Airflow Common SQL Provider: Remote Code Execution via Sql Injection

> Authenticated users can inject SQL via partition clauses in SQLTableCheckOperator to execute arbitrary commands and escalate privileges.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2025
- **Updated:** 26 Feb 2026
- **Also known as:** ECHO-d43e-4b7e-6cc8, GHSA-5r62-mjf5-xwhj, PYSEC-2026-1145, ROOT-APP-PYPI-CVE-2025-30473

## What is CVE-2025-30473?

CVE-2025-30473 is a high-severity SQL injection vulnerability in Apache Airflow Common SQL Provider, published on 7 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow Common SQL Provider.

When using the partition clause in SQLTableCheckOperator as parameter (which was a recommended pattern), Authenticated UI User could inject arbitrary SQL command when triggering DAG exposing partition_clause to the user.
This allowed the DAG Triggering user to escalate privileges to execute those arbitrary commands which they normally would not have.

This issue affects Apache Airflow Common SQL Provider: before 1.24.1.

Users are recommended to upgrade to version 1.24.1, which fixes the issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-30473?

3 open source packages ship an affected version, including apache-airflow-providers-common-sql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow-providers-common-sql` | PyPI | All versions | 1.24.1 |
| `apache-airflow-providers-common-sql` | PyPI | All versions | 1.24.1 |
| `apache-airflow-providers-common-sql` | PyPI | All versions | 1.24.1 |

Products: Apache Airflow Common Sql Provider.

## How do I fix CVE-2025-30473?

Upgrade apache-airflow-providers-common-sql to 1.24.1 or later.

## Is CVE-2025-30473 being exploited?

There is no known exploitation of CVE-2025-30473 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30473 and fix it if it is affected.

What it is: CVE-2025-30473 is a high-severity SQL injection vulnerability in Apache Airflow Common SQL Provider, published on 7 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30473 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow-providers-common-sql (PyPI): affected all versions; fixed in 1.24.1
- apache-airflow-providers-common-sql (PyPI): affected all versions; fixed in 1.24.1
- apache-airflow-providers-common-sql (PyPI): affected all versions; fixed in 1.24.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30473/ (Markdown: https://insights.sbomify.com/CVE-2025-30473/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30473
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30473
- OSV: https://osv.dev/vulnerability/CVE-2025-30473

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30473/
Summaries are generated and may contain mistakes; the official description above is the record.
