# CVE-2025-30474: Apache Commons VFS: Failing to find an FTP file can reveal the URI's password in an error message


- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Mar 2025
- **Updated:** 1 Apr 2025
- **Also known as:** DEBIAN-CVE-2025-30474, GHSA-3936-3gx6-49c4, UBUNTU-CVE-2025-30474

## What is CVE-2025-30474?

CVE-2025-30474 is a medium-severity vulnerability in Apache Commons VFS, published on 23 Mar 2025. 

### Official description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Commons VFS.

The FtpFileObject class can throw an exception when a file is not found, revealing the original URI in its message, which may include a password. The fix is to mask the password in the exception message
This issue affects Apache Commons VFS: before 2.10.0.

Users are recommended to upgrade to version 2.10.0, which fixes the issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-30474?

2 open source packages ship an affected version, including org.apache.commons:commons-vfs2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.commons:commons-vfs2` | Maven | All versions | 2.10.0 |
| `org.apache.commons:commons-vfs2` | Maven | All versions | 2.10.0 |

Products: Apache Commons Vfs.

## How do I fix CVE-2025-30474?

Upgrade org.apache.commons:commons-vfs2 to 2.10.0 or later.

## Is CVE-2025-30474 being exploited?

There is no known exploitation of CVE-2025-30474 in the wild and no public exploit code.

## Other vulnerabilities in Apache Commons VFS

- [CVE-2025-27553](https://insights.sbomify.com/CVE-2025-27553/): Apache Commons VFS: Possible path traversal issue when using NameScope.DESCENDENT (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30474 and fix it if it is affected.

What it is: CVE-2025-30474 is a medium-severity vulnerability in Apache Commons VFS, published on 23 Mar 2025. 
Exploitation: There is no known exploitation of CVE-2025-30474 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.commons:commons-vfs2 (Maven): affected all versions; fixed in 2.10.0
- org.apache.commons:commons-vfs2 (Maven): affected all versions; fixed in 2.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30474/ (Markdown: https://insights.sbomify.com/CVE-2025-30474/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30474
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30474
- OSV: https://osv.dev/vulnerability/CVE-2025-30474

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30474/
Summaries are generated and may contain mistakes; the official description above is the record.
