CVE-2025-3057 Drupal core - Critical - Cross site scripting - SA-CORE-2025-001
Drupal core contains a cross-site scripting vulnerability allowing attackers to inject malicious scripts, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-3057?
CVE-2025-3057 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.
Weakness: CWE-79
Which versions are affected by CVE-2025-3057?
10 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/core Packagist | From 10.4.0 | 10.4.3 |
drupal/core Packagist | From 10.4.0 | 10.4.3 |
drupal/core Packagist | From 11.0.0 | 11.0.12 |
drupal/core Packagist | From 11.0.0 | 11.0.12 |
drupal/core Packagist | From 11.1.0 | 11.1.3 |
drupal/core Packagist | From 11.1.0 | 11.1.3 |
4 more packages
drupal/core Packagist | From 8.0.0 | 10.3.13, 10.4.3, 11.0.12, 11.1.3 |
drupal/core Packagist | From 8.0.0 | 10.3.13 |
drupal/core Packagist | From 8.0.0 | 10.3.13 |
drupal Bitnami | From 8.0.0 | 10.4.3, 11.1.3 |
Products include Drupal Drupal.
How do I fix CVE-2025-3057?
Upgrade drupal/core to a fixed version for your release line: 10.4.3, 11.0.12, 11.1.3 or 10.3.13.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-3057 being exploited?
There is no known exploitation of CVE-2025-3057 in the wild and no public exploit code.
Other vulnerabilities in Drupal Drupal
Sources
Also known as BIT-drupal-2025-3057, DRUPAL-CORE-2025-001, GHSA-39g6-x4x8-5jcm.