CVE-2025-30677 Apache Pulsar Kafka Connector Logs Sensitive Information in Application Logs

Medium 6.3 Published Updated

Apache Pulsar Kafka connectors log sensitive credentials in plain text, exposing them to attackers with log access.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-30677?

CVE-2025-30677 is a medium-severity vulnerability in Apache Pulsar IO Kafka Connect Adaptor, published on 9 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs.

This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue.

This issue affects Apache Pulsar IO's Apache Kafka connectors in all versions before 3.0.11, 3.3.6, and 4.0.4.

3.0.x version users should upgrade to at least 3.0.11.

3.3.x version users should upgrade to at least 3.3.6.

4.0.x version users should upgrade to at least 4.0.4.

Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Weakness: CWE-532

Which versions are affected by CVE-2025-30677?

12 open source packages ship an affected version, including org.apache.pulsar:pulsar-io-kafka-connect-adaptor and org.apache.pulsar:pulsar-io-kafka. It affects 1 product.

PackageAffectedFixed in
org.apache.pulsar:pulsar-io-kafka-connect-adaptor MavenAll versions3.0.11
org.apache.pulsar:pulsar-io-kafka-connect-adaptor MavenAll versions3.0.11
org.apache.pulsar:pulsar-io-kafka-connect-adaptor MavenFrom 3.3.03.3.6
org.apache.pulsar:pulsar-io-kafka-connect-adaptor MavenFrom 3.3.03.3.6
org.apache.pulsar:pulsar-io-kafka-connect-adaptor MavenFrom 4.0.04.0.4
org.apache.pulsar:pulsar-io-kafka-connect-adaptor MavenFrom 4.0.04.0.4
6 more packages
org.apache.pulsar:pulsar-io-kafka MavenAll versions3.0.11
org.apache.pulsar:pulsar-io-kafka MavenAll versions3.0.11
org.apache.pulsar:pulsar-io-kafka MavenFrom 3.3.03.3.6
org.apache.pulsar:pulsar-io-kafka MavenFrom 3.3.03.3.6
org.apache.pulsar:pulsar-io-kafka MavenFrom 4.0.04.0.4
org.apache.pulsar:pulsar-io-kafka MavenFrom 4.0.04.0.4

Products include Apache Pulsar.

How do I fix CVE-2025-30677?

Upgrade org.apache.pulsar:pulsar-io-kafka-connect-adaptor to a fixed version for your release line: 3.0.11, 3.3.6 or 4.0.4.

Is CVE-2025-30677 being exploited?

There is no known exploitation of CVE-2025-30677 in the wild and no public exploit code.

Sources

Also known as GHSA-rcqj-3fmp-5cqx.

Is CVE-2025-30677 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free