# CVE-2025-30677: Apache Pulsar Kafka Connector Logs Sensitive Information in Application Logs

> Apache Pulsar Kafka connectors log sensitive credentials in plain text, exposing them to attackers with log access.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2025
- **Updated:** 9 Apr 2025
- **Also known as:** GHSA-rcqj-3fmp-5cqx

## What is CVE-2025-30677?

CVE-2025-30677 is a medium-severity vulnerability in Apache Pulsar IO Kafka Connect Adaptor, published on 9 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Pulsar contains multiple connectors for integrating with Apache Kafka. The Pulsar IO Apache Kafka Source Connector, Sink Connector, and Kafka Connect Adaptor Sink Connector log sensitive configuration properties in plain text in application logs.

This vulnerability can lead to unintended exposure of credentials in log files, potentially allowing attackers with access to these logs to obtain Apache Kafka credentials. The vulnerability's impact is limited by the fact that an attacker would need access to the application logs to exploit this issue.

This issue affects Apache Pulsar IO's Apache Kafka connectors in all versions before 3.0.11, 3.3.6, and 4.0.4.

3.0.x version users should upgrade to at least 3.0.11.

3.3.x version users should upgrade to at least 3.3.6.

4.0.x version users should upgrade to at least 4.0.4.

Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2025-30677?

12 open source packages ship an affected version, including org.apache.pulsar:pulsar-io-kafka-connect-adaptor and org.apache.pulsar:pulsar-io-kafka. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pulsar:pulsar-io-kafka-connect-adaptor` | Maven | All versions | 3.0.11 |
| `org.apache.pulsar:pulsar-io-kafka-connect-adaptor` | Maven | All versions | 3.0.11 |
| `org.apache.pulsar:pulsar-io-kafka-connect-adaptor` | Maven | From 3.3.0 | 3.3.6 |
| `org.apache.pulsar:pulsar-io-kafka-connect-adaptor` | Maven | From 3.3.0 | 3.3.6 |
| `org.apache.pulsar:pulsar-io-kafka-connect-adaptor` | Maven | From 4.0.0 | 4.0.4 |
| `org.apache.pulsar:pulsar-io-kafka-connect-adaptor` | Maven | From 4.0.0 | 4.0.4 |
| `org.apache.pulsar:pulsar-io-kafka` | Maven | All versions | 3.0.11 |
| `org.apache.pulsar:pulsar-io-kafka` | Maven | All versions | 3.0.11 |
| `org.apache.pulsar:pulsar-io-kafka` | Maven | From 3.3.0 | 3.3.6 |
| `org.apache.pulsar:pulsar-io-kafka` | Maven | From 3.3.0 | 3.3.6 |
| `org.apache.pulsar:pulsar-io-kafka` | Maven | From 4.0.0 | 4.0.4 |
| `org.apache.pulsar:pulsar-io-kafka` | Maven | From 4.0.0 | 4.0.4 |

Products: Apache Pulsar.

## How do I fix CVE-2025-30677?

Upgrade org.apache.pulsar:pulsar-io-kafka-connect-adaptor to a fixed version for your release line: 3.0.11, 3.3.6 or 4.0.4.

## Is CVE-2025-30677 being exploited?

There is no known exploitation of CVE-2025-30677 in the wild and no public exploit code.

## Other vulnerabilities in Apache Pulsar IO Kafka Connect Adaptor

- [CVE-2021-22160](https://insights.sbomify.com/CVE-2021-22160/): Authentication with JWT allows use of “none”-algorithm (critical 9.8)
- [CVE-2023-30429](https://insights.sbomify.com/CVE-2023-30429/): Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy (critical 9.6)
- [CVE-2024-27135](https://insights.sbomify.com/CVE-2024-27135/): Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution (high 8.5)
- [CVE-2024-27894](https://insights.sbomify.com/CVE-2024-27894/): Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying (high 8.5)
- [CVE-2024-27317](https://insights.sbomify.com/CVE-2024-27317/): Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30677 and fix it if it is affected.

What it is: CVE-2025-30677 is a medium-severity vulnerability in Apache Pulsar IO Kafka Connect Adaptor, published on 9 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30677 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.pulsar:pulsar-io-kafka-connect-adaptor (Maven): affected all versions; fixed in 3.0.11
- org.apache.pulsar:pulsar-io-kafka-connect-adaptor (Maven): affected all versions; fixed in 3.0.11
- org.apache.pulsar:pulsar-io-kafka-connect-adaptor (Maven): affected from 3.3.0; fixed in 3.3.6
- org.apache.pulsar:pulsar-io-kafka-connect-adaptor (Maven): affected from 3.3.0; fixed in 3.3.6
- org.apache.pulsar:pulsar-io-kafka-connect-adaptor (Maven): affected from 4.0.0; fixed in 4.0.4
- org.apache.pulsar:pulsar-io-kafka-connect-adaptor (Maven): affected from 4.0.0; fixed in 4.0.4
- org.apache.pulsar:pulsar-io-kafka (Maven): affected all versions; fixed in 3.0.11
- org.apache.pulsar:pulsar-io-kafka (Maven): affected all versions; fixed in 3.0.11
- org.apache.pulsar:pulsar-io-kafka (Maven): affected from 3.3.0; fixed in 3.3.6
- org.apache.pulsar:pulsar-io-kafka (Maven): affected from 3.3.0; fixed in 3.3.6
- org.apache.pulsar:pulsar-io-kafka (Maven): affected from 4.0.0; fixed in 4.0.4
- org.apache.pulsar:pulsar-io-kafka (Maven): affected from 4.0.0; fixed in 4.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30677/ (Markdown: https://insights.sbomify.com/CVE-2025-30677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30677
- OSV: https://osv.dev/vulnerability/CVE-2025-30677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30677/
Summaries are generated and may contain mistakes; the official description above is the record.
