CVE-2025-30691 Security feature bypass in Oracle Java SE
An unauthenticated attacker can bypass security restrictions in the Java Compiler to read and modify accessible data via network protocols.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-30691?
CVE-2025-30691 is a medium-severity vulnerability in Netapp Bootstrap Os, published on 15 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in Oracle Java SE (component: Compiler). Supported versions that are affected are Oracle Java SE: 21.0.6, 24; Oracle GraalVM for JDK: 21.0.6 and 24. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of Oracle Java SE accessible data as well as unauthorized read access to a subset of Oracle Java SE accessible data. Note: This vulnerability can be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. This vulnerability also applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. CVSS 3.1 Base Score 4.8 (Confidentiality and Integrity impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N).
Weakness: CWE-284
Which versions are affected by CVE-2025-30691?
3 open source packages ship an affected version, including java, java-min and jre. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | From 18.0.0 | 21.0.7, 24.0.1 |
java-min Bitnami | From 18.0.0 | 21.0.7, 24.0.1 |
jre Bitnami | From 18.0.0 | 21.0.7, 24.0.1 |
Products include Netapp Bootstrap Os, Oracle Graalvm for Jdk, Oracle Jdk, Oracle Jre.
How do I fix CVE-2025-30691?
Upgrade java to a fixed version for your release line: 21.0.7 or 24.0.1.
Is CVE-2025-30691 being exploited?
There is no known exploitation of CVE-2025-30691 in the wild and no public exploit code.
Other vulnerabilities in Netapp Bootstrap Os
- CVE-2024-43398 REXML denial of service vulnerability
- CVE-2024-43790 heap-buffer-overflow in do_search() in Vim < 9.1.0689
- CVE-2025-29768 Vim vulnerable to potential data loss with zip.vim and special crafted zip files
- CVE-2024-39908 Denial of service in REXML
- CVE-2024-47814 use-after-free when closing buffers in Vim
Sources
Also known as BIT-java-2025-30691, BIT-java-min-2025-30691, BIT-jre-2025-30691, CLEANSTART-2026-RV35406, DEBIAN-CVE-2025-30691, GHSA-qh4r-w9x4-6fq2 and 7 more.