# CVE-2025-30691: Security feature bypass in Oracle Java SE

> An unauthenticated attacker can bypass security restrictions in the Java Compiler to read and modify accessible data via network protocols.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2025
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-java-2025-30691, BIT-java-min-2025-30691, BIT-jre-2025-30691, CLEANSTART-2026-RV35406, DEBIAN-CVE-2025-30691, GHSA-qh4r-w9x4-6fq2, MINI-7j2v-8fj3-6ffc, MINI-cfg7-pchc-74j2, MINI-gmfj-w273-3665, MINI-hfgf-c7f7-m7pm, MINI-q55m-wf3f-cc56, MINI-qqcp-j8fh-mc7q, UBUNTU-CVE-2025-30691

## What is CVE-2025-30691?

CVE-2025-30691 is a medium-severity vulnerability in Netapp Bootstrap Os, published on 15 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in Oracle Java SE (component: Compiler).  Supported versions that are affected are Oracle Java SE: 21.0.6, 24; Oracle GraalVM for JDK: 21.0.6 and  24. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE.  Successful attacks of this vulnerability can result in  unauthorized update, insert or delete access to some of Oracle Java SE accessible data as well as  unauthorized read access to a subset of Oracle Java SE accessible data. Note: This vulnerability can be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. This vulnerability also applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. CVSS 3.1 Base Score 4.8 (Confidentiality and Integrity impacts).  CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N).

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-30691?

3 open source packages ship an affected version, including java, java-min and jre. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | From 18.0.0 | 21.0.7, 24.0.1 |
| `java-min` | Bitnami | From 18.0.0 | 21.0.7, 24.0.1 |
| `jre` | Bitnami | From 18.0.0 | 21.0.7, 24.0.1 |

Products: Netapp Bootstrap Os, Oracle Graalvm for Jdk, Oracle Jdk, Oracle Jre.

## How do I fix CVE-2025-30691?

Upgrade java to a fixed version for your release line: 21.0.7 or 24.0.1.

## Is CVE-2025-30691 being exploited?

There is no known exploitation of CVE-2025-30691 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Bootstrap Os

- [CVE-2024-43398](https://insights.sbomify.com/CVE-2024-43398/): REXML denial of service vulnerability (medium 5.9)
- [CVE-2024-43790](https://insights.sbomify.com/CVE-2024-43790/): heap-buffer-overflow in do_search() in Vim < 9.1.0689 (medium 4.5)
- [CVE-2025-29768](https://insights.sbomify.com/CVE-2025-29768/): Vim vulnerable to potential data loss with zip.vim and special crafted zip files (medium 4.4)
- [CVE-2024-39908](https://insights.sbomify.com/CVE-2024-39908/): Denial of service in REXML (medium 4.3)
- [CVE-2024-47814](https://insights.sbomify.com/CVE-2024-47814/): use-after-free when closing buffers in Vim (low 3.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30691 and fix it if it is affected.

What it is: CVE-2025-30691 is a medium-severity vulnerability in Netapp Bootstrap Os, published on 15 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30691 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected from 18.0.0; fixed in 21.0.7, 24.0.1
- java-min (Bitnami): affected from 18.0.0; fixed in 21.0.7, 24.0.1
- jre (Bitnami): affected from 18.0.0; fixed in 21.0.7, 24.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30691/ (Markdown: https://insights.sbomify.com/CVE-2025-30691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30691
- OSV: https://osv.dev/vulnerability/CVE-2025-30691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30691/
Summaries are generated and may contain mistakes; the official description above is the record.
