# CVE-2025-30741: Pixelfed may allow unauthorized actor to view private posts and private users

> Attackers can bypass privacy controls to follow private accounts and view private posts on other Fediverse servers via Pixelfed instances.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2025
- **Updated:** 26 Mar 2025
- **Also known as:** GHSA-7287-grhx-542x

## What is CVE-2025-30741?

CVE-2025-30741 is a medium-severity missing authorization vulnerability in Pixelfed, published on 25 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pixelfed before 0.12.5 allows anyone to follow private accounts and see private posts on other Fediverse servers. This affects users elsewhere in the Fediverse, if they otherwise have any followers from a Pixelfed instance.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-30741?

2 open source packages ship an affected version, including pixelfed/pixelfed.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pixelfed/pixelfed` | Packagist | All versions | 0.12.5 |
| `pixelfed/pixelfed` | Packagist | All versions | 0.12.5 |

## How do I fix CVE-2025-30741?

Upgrade pixelfed/pixelfed to 0.12.5 or later.

## Is CVE-2025-30741 being exploited?

There is no known exploitation of CVE-2025-30741 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-30741 and fix it if it is affected.

What it is: CVE-2025-30741 is a medium-severity missing authorization vulnerability in Pixelfed, published on 25 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-30741 in the wild and no public exploit code.

Affected packages and fixed versions:
- pixelfed/pixelfed (Packagist): affected all versions; fixed in 0.12.5
- pixelfed/pixelfed (Packagist): affected all versions; fixed in 0.12.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-30741/ (Markdown: https://insights.sbomify.com/CVE-2025-30741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-30741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-30741
- OSV: https://osv.dev/vulnerability/CVE-2025-30741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-30741/
Summaries are generated and may contain mistakes; the official description above is the record.
