CVE-2025-30752 Denial of service in Oracle GraalVM for JDK
An unauthenticated attacker can cause a partial denial of service in Oracle Java SE and GraalVM via the compiler component.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-30752?
CVE-2025-30752 is a low-severity denial of service vulnerability in Oracle Graalvm for Jdk, published on 15 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in the Oracle Java SE, Oracle GraalVM for JDK product of Oracle Java SE (component: Compiler). The supported version that is affected is Oracle Java SE: 24.0.1; Oracle GraalVM for JDK: 24.0.1. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM for JDK. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Oracle Java SE, Oracle GraalVM for JDK. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability does not apply to Java deployments, typically in servers, that load and run only trusted code (e.g., code installed by an administrator). CVSS 3.1 Base Score 3.7 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L).
Weakness: CWE-400
Which versions are affected by CVE-2025-30752?
3 open source packages ship an affected version, including java, java-min and jre. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | From 22.0.0 | 24.0.2 |
java-min Bitnami | From 22.0.0 | 24.0.2 |
jre Bitnami | From 22.0.0 | 24.0.2 |
Products include Oracle Graalvm for Jdk, Oracle Jdk, Oracle Jre.
How do I fix CVE-2025-30752?
Upgrade java to 24.0.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-30752 being exploited?
There is no known exploitation of CVE-2025-30752 in the wild and no public exploit code.
Other vulnerabilities in Oracle Graalvm for Jdk
Sources
Also known as BIT-java-2025-30752, BIT-java-min-2025-30752, BIT-jre-2025-30752, GHSA-ffx9-x7f3-xr9v, MINI-c2rh-2374-c5wm, MINI-pmxq-rxjw-8q4x and 2 more.