CVE-2025-3082 User may override a view's collation and gain unauthorized access to underlying data

Low 3.1 Published Updated

Authorized users can override view collations to access unintended underlying data, requiring database administrators to upgrade MongoDB Server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-3082?

CVE-2025-3082 is a low-severity missing authorization vulnerability in Mongodb Mongodb, published on 1 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A user authorized to access a view may be able to alter the intended collation, allowing them to access to a different or unintended view of underlying data. This issue affects MongoDB Server v5.0 version prior to 5.0.31, MongoDB Server v6.0 version prior to 6.0.20, MongoDB Server v7.0 version prior to 7.0.14 and MongoDB Server v7.3 versions prior to 7.3.4.

Weakness: CWE-284

Which versions are affected by CVE-2025-3082?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 5.0.05.0.31, 6.0.20, 7.0.14, 7.3.4

Products include Mongodb Mongodb.

How do I fix CVE-2025-3082?

Upgrade mongodb to a fixed version for your release line: 5.0.31, 6.0.20, 7.0.14 or 7.3.4.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-3082 being exploited?

There is no known exploitation of CVE-2025-3082 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2025-3082, GHSA-77w4-3h74-q5hf, UBUNTU-CVE-2025-3082.

Is CVE-2025-3082 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free