{"answers":{"affected":"1 open source package ship an affected version, including mongodb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-3082 in the wild and no public exploit code.","fix":"Upgrade mongodb to a fixed version for your release line: 5.0.31, 6.0.20, 7.0.14 or 7.3.4.","what":"CVE-2025-3082 is a low-severity missing authorization vulnerability in Mongodb Mongodb, published on 1 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-3082 and fix it if it is affected.\n\nWhat it is: CVE-2025-3082 is a low-severity missing authorization vulnerability in Mongodb Mongodb, published on 1 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-3082 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mongodb (Bitnami): affected from 5.0.0; fixed in 5.0.31, 6.0.20, 7.0.14, 7.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-3082/ (Markdown: https://insights.sbomify.com/CVE-2025-3082/index.md)","id":"CVE-2025-3082","markdown":"https://insights.sbomify.com/CVE-2025-3082/index.md","name":"CVE-2025-3082","record":{"aliases":["BIT-mongodb-2025-3082","GHSA-77w4-3h74-q5hf","UBUNTU-CVE-2025-3082"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"MongoDB Server","requires_auth":"low_privilege","summary":"Authorized users can override view collations to access unintended underlying data, requiring database administrators to upgrade MongoDB Server.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mongodb","cpe":[{"product":"mongodb","vendor":"mongodb"}],"cvss":{"score":3.1,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"A user authorized to access a view may be able to alter the intended collation, allowing them to access to a different or unintended view of underlying data. This issue affects MongoDB Server v5.0 version prior to 5.0.31, MongoDB Server v6.0 version prior to 6.0.20, MongoDB Server v7.0 version prior to 7.0.14 and MongoDB Server v7.3 versions prior to 7.3.4.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"User may override a view's collation and gain unauthorized access to underlying data","id":"CVE-2025-3082","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"mongodb:mongodb","products":["mongodb:mongodb"],"type":"missing_authorization","year":"2025"},"n_packages":1,"n_references":1,"next":{"headline":"Malformed MongoDB wire protocol messages may cause mongos to crash","id":"CVE-2025-3083"},"packages":[{"ecosystem":"Bitnami","fixed":["5.0.31","6.0.20","7.0.14","7.3.4"],"introduced":["5.0.0","6.0.0","7.0.0","7.3.0"],"last_affected":[],"package":"mongodb","purl":"pkg:bitnami/mongodb","source":"BIT-mongodb-2025-3082"}],"prev":{"headline":"Information disclosure in Satera Series","id":"CVE-2025-3079"},"products":["MongoDB Server"],"published":"2025-04-01","related":[{"cvss_score":8.7,"headline":"MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency","id":"CVE-2025-14847","kev_date_added":"2025-12-29","published":"2025-12-19"},{"cvss_score":9.2,"headline":"Auth bypass in MongoDB Server","id":"CVE-2026-82067","kev_date_added":null,"published":"2026-09-08"},{"cvss_score":9.2,"headline":"MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption","id":"CVE-2026-13072","kev_date_added":null,"published":"2026-07-22"},{"cvss_score":9.1,"headline":"Denial of service in n/a","id":"CVE-2017-15535","kev_date_added":null,"published":"2017-11-01"},{"cvss_score":9,"headline":"Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure","id":"CVE-2026-18691","kev_date_added":null,"published":"2026-08-11"},{"cvss_score":8.8,"headline":"MongoDB Server may allow successful untrusted connection","id":"CVE-2024-1351","kev_date_added":null,"published":"2024-03-07"},{"cvss_score":8.7,"headline":"Denial of service in MongoDB Server","id":"CVE-2026-82064","kev_date_added":null,"published":"2026-09-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-01","vendors":["MongoDB Inc"]},"summary":"Authorized users can override view collations to access unintended underlying data, requiring database administrators to upgrade MongoDB Server.","url":"https://insights.sbomify.com/CVE-2025-3082/"}