CVE-2025-3084 MongoDB Server may crash due to improper validation of explain command

Medium 6.5 Published Updated

Attackers can crash MongoDB router servers by sending malformed explain commands, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-3084?

CVE-2025-3084 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 1 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

When run on commands with certain arguments set, explain may fail to validate these arguments before using them. This can lead to crashes in router servers. This affects MongoDB Server v5.0 prior to 5.0.31, MongoDB Server v6.0 prior to 6.0.20, MongoDB Server v7.0 prior to 7.0.16 and MongoDB Server v8.0 prior to 8.0.4

Weakness: CWE-703

Which versions are affected by CVE-2025-3084?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 5.0.05.0.31, 6.0.20, 7.0.16, 8.0.4

Products include Mongodb Mongodb.

How do I fix CVE-2025-3084?

Upgrade mongodb to a fixed version for your release line: 5.0.31, 6.0.20, 7.0.16 or 8.0.4.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-3084 being exploited?

There is no known exploitation of CVE-2025-3084 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2025-3084, GHSA-75j9-xw79-qxqv, UBUNTU-CVE-2025-3084.

Is CVE-2025-3084 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free