# CVE-2025-3084: MongoDB Server may crash due to improper validation of explain command

> Attackers can crash MongoDB router servers by sending malformed explain commands, requiring an upgrade to patched versions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2025
- **Updated:** 1 Apr 2025
- **Also known as:** BIT-mongodb-2025-3084, GHSA-75j9-xw79-qxqv, UBUNTU-CVE-2025-3084

## What is CVE-2025-3084?

CVE-2025-3084 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 1 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

When run on commands with certain arguments set, explain may fail to validate these arguments before using them. This can lead to crashes in router servers. This affects MongoDB Server v5.0 prior to 5.0.31, MongoDB Server v6.0 prior to 6.0.20, MongoDB Server v7.0 prior to 7.0.16 and MongoDB Server v8.0 prior to 8.0.4

Weakness: CWE-703 (Improper Check or Handling of Exceptional Conditions)

## Which versions are affected by CVE-2025-3084?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 5.0.0 | 5.0.31, 6.0.20, 7.0.16, 8.0.4 |

Products: Mongodb Mongodb.

## How do I fix CVE-2025-3084?

Upgrade mongodb to a fixed version for your release line: 5.0.31, 6.0.20, 7.0.16 or 8.0.4.

## Is CVE-2025-3084 being exploited?

There is no known exploitation of CVE-2025-3084 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3084 and fix it if it is affected.

What it is: CVE-2025-3084 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 1 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3084 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 5.0.0; fixed in 5.0.31, 6.0.20, 7.0.16, 8.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3084/ (Markdown: https://insights.sbomify.com/CVE-2025-3084/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3084
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3084
- OSV: https://osv.dev/vulnerability/CVE-2025-3084

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3084/
Summaries are generated and may contain mistakes; the official description above is the record.
