CVE-2025-3085 MongoDB Server running on Linux may allow unexpected connections where intermediate certificates are revoked

High 8.1 Published Updated

Attackers can bypass authentication using revoked intermediate certificates when CRL checking is enabled on Linux MongoDB servers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-3085?

CVE-2025-3085 is a high-severity authentication bypass vulnerability in Mongodb Mongodb, published on 1 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A MongoDB server under specific conditions running on Linux with TLS and CRL revocation status checking enabled, fails to check the revocation status of the intermediate certificates in the peer's certificate chain. In cases of MONGODB-X509, which is not enabled by default, this may lead to improper authentication. This issue may also affect intra-cluster authentication. This issue affects MongoDB Server v5.0 versions prior to 5.0.31, MongoDB Server v6.0 versions prior to 6.0.20, MongoDB Server v7.0 versions prior to 7.0.16 and MongoDB Server v8.0 versions prior to 8.0.4. Required Configuration : MongoDB Server must be running on Linux Operating Systems and CRL revocation status checking must be enabled

Weakness: CWE-299

Which versions are affected by CVE-2025-3085?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 5.0.05.0.31, 6.0.20, 7.0.16, 8.0.4

Products include Mongodb Mongodb.

How do I fix CVE-2025-3085?

Upgrade mongodb to a fixed version for your release line: 5.0.31, 6.0.20, 7.0.16 or 8.0.4.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-3085 being exploited?

There is no known exploitation of CVE-2025-3085 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2025-3085, GHSA-v8j7-gw8h-m2j4, UBUNTU-CVE-2025-3085.

Is CVE-2025-3085 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free