# CVE-2025-3085: MongoDB Server running on Linux may allow unexpected connections where intermediate certificates are revoked

> Attackers can bypass authentication using revoked intermediate certificates when CRL checking is enabled on Linux MongoDB servers.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2025
- **Updated:** 1 Apr 2025
- **Also known as:** BIT-mongodb-2025-3085, GHSA-v8j7-gw8h-m2j4, UBUNTU-CVE-2025-3085

## What is CVE-2025-3085?

CVE-2025-3085 is a high-severity authentication bypass vulnerability in Mongodb Mongodb, published on 1 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A MongoDB server under specific conditions running on Linux with TLS and CRL revocation status checking enabled, fails to check the revocation status of the intermediate certificates in the peer's certificate chain. In cases of MONGODB-X509, which is not enabled by default, this may lead to improper authentication. This issue may also affect intra-cluster authentication. This issue affects MongoDB Server v5.0 versions prior to 5.0.31, MongoDB Server v6.0 versions prior to 6.0.20, MongoDB Server v7.0 versions prior to 7.0.16 and MongoDB Server v8.0 versions prior to 8.0.4.
Required Configuration : MongoDB Server must be running on Linux Operating Systems and CRL revocation status checking must be enabled

Weakness: CWE-299 (Improper Check for Certificate Revocation)

## Which versions are affected by CVE-2025-3085?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 5.0.0 | 5.0.31, 6.0.20, 7.0.16, 8.0.4 |

Products: Mongodb Mongodb.

## How do I fix CVE-2025-3085?

Upgrade mongodb to a fixed version for your release line: 5.0.31, 6.0.20, 7.0.16 or 8.0.4.

## Is CVE-2025-3085 being exploited?

There is no known exploitation of CVE-2025-3085 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3085 and fix it if it is affected.

What it is: CVE-2025-3085 is a high-severity authentication bypass vulnerability in Mongodb Mongodb, published on 1 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-3085 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 5.0.0; fixed in 5.0.31, 6.0.20, 7.0.16, 8.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3085/ (Markdown: https://insights.sbomify.com/CVE-2025-3085/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3085
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3085
- OSV: https://osv.dev/vulnerability/CVE-2025-3085

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3085/
Summaries are generated and may contain mistakes; the official description above is the record.
