# CVE-2025-3108: Unsafe Deserialization in JsonPickleSerializer Enables Remote Code Execution in run-llama/llama_index

> Attackers can achieve remote code execution by exploiting unsafe pickle deserialization in the JsonPickleSerializer component of the llama_index library.

- **Severity:** Medium 5.0 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Jul 2025
- **Updated:** 7 Jul 2025
- **Also known as:** GHSA-m84c-4c34-28gf, PYSEC-2025-249, PYSEC-2026-1564

## What is CVE-2025-3108?

CVE-2025-3108 is a medium-severity unsafe deserialization vulnerability in run-llama/llama_index, published on 6 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A critical deserialization vulnerability exists in the run-llama/llama_index library's JsonPickleSerializer component, affecting versions v0.12.27 through v0.12.40. This vulnerability allows remote code execution due to an insecure fallback to Python's pickle module. JsonPickleSerializer prioritizes deserialization using pickle.loads(), which can execute arbitrary code when processing untrusted data. Attackers can exploit this by crafting malicious payloads to achieve full system compromise. The root cause includes an insecure fallback mechanism, lack of validation or safeguards, misleading design, and violation of Python security guidelines.

Weakness: CWE-1112 (Incomplete Documentation of Program Execution)

## Which versions are affected by CVE-2025-3108?

4 open source packages ship an affected version, including llama-index-core and llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-core` | PyPI | From 0.11.15 | 0.12.41 |
| `llama-index-core` | PyPI | From 0.11.15 | 0.12.41 |
| `llama-index-core` | PyPI | From 0.11.15 | 0.12.41 |
| `llama-index` | PyPI | From 0.12.27 | 0.12.41 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2025-3108?

Upgrade llama-index-core to 0.12.41 or later.

## Is CVE-2025-3108 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3108 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3108 and fix it if it is affected.

What it is: CVE-2025-3108 is a medium-severity unsafe deserialization vulnerability in run-llama/llama_index, published on 6 Jul 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3108 exists.

Affected packages and fixed versions:
- llama-index-core (PyPI): affected from 0.11.15; fixed in 0.12.41
- llama-index-core (PyPI): affected from 0.11.15; fixed in 0.12.41
- llama-index-core (PyPI): affected from 0.11.15; fixed in 0.12.41
- llama-index (PyPI): affected from 0.12.27; fixed in 0.12.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3108/ (Markdown: https://insights.sbomify.com/CVE-2025-3108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3108
- OSV: https://osv.dev/vulnerability/CVE-2025-3108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3108/
Summaries are generated and may contain mistakes; the official description above is the record.
