# CVE-2025-31119: CWE-470 in generator-jhipster-entity-audit when having Javers selected as Entity Audit Framework

> Attackers with classpath access can trigger remote code execution via unsafe reflection in the Javers audit framework.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Apr 2025
- **Updated:** 3 Apr 2025
- **Also known as:** GHSA-7rmp-3g9f-cvq8

## What is CVE-2025-31119?

CVE-2025-31119 is a high-severity code injection vulnerability in generator-jhipster-entity-audit, published on 3 Apr 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

generator-jhipster-entity-audit is a JHipster module to enable entity audit and audit log page. Prior to 5.9.1, generator-jhipster-entity-audit allows unsafe reflection when having Javers selected as Entity Audit Framework. If an attacker manages to place some malicious classes into the classpath and also has access to these REST interface for calling the mentioned REST endpoints, using these lines of code can lead to unintended remote code execution. This vulnerability is fixed in 5.9.1.

Weakness: CWE-470 (Use of Externally-Controlled Input to Select Classes or Code)

## Which versions are affected by CVE-2025-31119?

2 open source packages ship an affected version, including generator-jhipster-entity-audit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `generator-jhipster-entity-audit` | npm | All versions | 5.9.1 |
| `generator-jhipster-entity-audit` | npm | All versions | 5.9.1 |

## How do I fix CVE-2025-31119?

Upgrade generator-jhipster-entity-audit to 5.9.1 or later.

## Is CVE-2025-31119 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-31119 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31119 and fix it if it is affected.

What it is: CVE-2025-31119 is a high-severity code injection vulnerability in generator-jhipster-entity-audit, published on 3 Apr 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-31119 exists.

Affected packages and fixed versions:
- generator-jhipster-entity-audit (npm): affected all versions; fixed in 5.9.1
- generator-jhipster-entity-audit (npm): affected all versions; fixed in 5.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31119/ (Markdown: https://insights.sbomify.com/CVE-2025-31119/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31119
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31119
- OSV: https://osv.dev/vulnerability/CVE-2025-31119

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31119/
Summaries are generated and may contain mistakes; the official description above is the record.
