CVE-2025-31128 gifplayer XSS vulnerability

Medium 6.9 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2025-31128?

CVE-2025-31128 is a medium-severity vulnerability in rubentd gifplayer, published on 31 Mar 2025.

Official description

gifplayer is a customizable jquery plugin to play and stop animated gifs. gifplayer contains a cross-site scripting (XSS) vulnerability. This vulnerability is fixed in 0.3.7.

Weakness: CWE-79

Which versions are affected by CVE-2025-31128?

2 open source packages ship an affected version, including gifplayer.

PackageAffectedFixed in
gifplayer npmAll versions0.3.7
gifplayer npmAll versions0.3.7
Linux distribution packages (1)
drupal/gifplayer Packagist:https://packages.drupal.org/8All versions1.5.0, 2.0.4

How do I fix CVE-2025-31128?

Upgrade gifplayer to 0.3.7 or later.

Is CVE-2025-31128 being exploited?

There is no known exploitation of CVE-2025-31128 in the wild and no public exploit code.

Sources

Also known as DRUPAL-CONTRIB-2025-032, GHSA-gr7w-hmch-25g7.

Is CVE-2025-31128 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free