# CVE-2025-31128: gifplayer XSS vulnerability


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 31 Mar 2025
- **Updated:** 12 Jun 2025
- **Also known as:** DRUPAL-CONTRIB-2025-032, GHSA-gr7w-hmch-25g7

## What is CVE-2025-31128?

CVE-2025-31128 is a medium-severity vulnerability in rubentd gifplayer, published on 31 Mar 2025. 

### Official description

gifplayer is a customizable jquery plugin to play and stop animated gifs. gifplayer contains a cross-site scripting (XSS) vulnerability. This vulnerability is fixed in 0.3.7.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-31128?

2 open source packages ship an affected version, including gifplayer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gifplayer` | npm | All versions | 0.3.7 |
| `gifplayer` | npm | All versions | 0.3.7 |
| `drupal/gifplayer` | Packagist:https://packages.drupal.org/8 | All versions | 1.5.0, 2.0.4 |

## How do I fix CVE-2025-31128?

Upgrade gifplayer to 0.3.7 or later.

## Is CVE-2025-31128 being exploited?

There is no known exploitation of CVE-2025-31128 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31128 and fix it if it is affected.

What it is: CVE-2025-31128 is a medium-severity vulnerability in rubentd gifplayer, published on 31 Mar 2025. 
Exploitation: There is no known exploitation of CVE-2025-31128 in the wild and no public exploit code.

Affected packages and fixed versions:
- gifplayer (npm): affected all versions; fixed in 0.3.7
- gifplayer (npm): affected all versions; fixed in 0.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31128/ (Markdown: https://insights.sbomify.com/CVE-2025-31128/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31128
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31128
- OSV: https://osv.dev/vulnerability/CVE-2025-31128

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31128/
Summaries are generated and may contain mistakes; the official description above is the record.
