# CVE-2025-31131: Path Traversal allowing arbitrary read of files in Yeswiki

> Attackers can read arbitrary files on the server via path traversal in the squelette parameter of YesWiki.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2025
- **Updated:** 1 Apr 2025
- **Also known as:** GHSA-w34w-fvp3-68xm

## What is CVE-2025-31131?

CVE-2025-31131 is a high-severity path traversal vulnerability in yeswiki, published on 1 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. The squelette parameter is vulnerable to path traversal attacks, enabling read access to arbitrary files on the server. This vulnerability is fixed in 4.5.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-31131?

2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.5.2 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.5.2 |

Products: Yeswiki Yeswiki.

## How do I fix CVE-2025-31131?

Upgrade yeswiki/yeswiki to 4.5.2 or later.

## Is CVE-2025-31131 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-31131 exists.

Public exploit code:

- YesWiki is a wiki system written in PHP. The squelette parameter is vulnerable to path traversal attacks, enabling read access to arbitrary files on the server. (github_poc): https://github.com/MuhammadWaseem29/CVE-2025-31131
- YesWiki 4.5.1 - Unauthenticated Path Traversal (exploitdb)
- CVE-2025-31131 (github_poc): https://github.com/gmh5225/Blackash-CVE-2025-31131
- Yeswiki < 4.5.2 - Unauthenticated Path Traversal (nuclei): http/cves/2025/CVE-2025-31131.yaml

## Other vulnerabilities in yeswiki

- [CVE-2025-46348](https://insights.sbomify.com/CVE-2025-46348/): YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download (critical 10.0)
- [CVE-2024-51478](https://insights.sbomify.com/CVE-2024-51478/): Use of a Broken or Risky Cryptographic Algorithm in YesWiki (critical 9.9)
- [CVE-2018-1000641](https://insights.sbomify.com/CVE-2018-1000641/): Deserialization in n/a (critical 9.8)
- [CVE-2025-46349](https://insights.sbomify.com/CVE-2025-46349/): YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting (high 7.6)
- [CVE-2025-24017](https://insights.sbomify.com/CVE-2025-24017/): YesWiki Vulnerable to Unauthenticated DOM Based XSS (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31131 and fix it if it is affected.

What it is: CVE-2025-31131 is a high-severity path traversal vulnerability in yeswiki, published on 1 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-31131 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.2
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31131/ (Markdown: https://insights.sbomify.com/CVE-2025-31131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31131
- OSV: https://osv.dev/vulnerability/CVE-2025-31131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31131/
Summaries are generated and may contain mistakes; the official description above is the record.
