# CVE-2025-31136: FreshRSS vulnerable to Cross-site Scripting by <iframe>'ing a vulnerable same-origin page in a feed entry

> Attacker-controlled feed entries can execute arbitrary JavaScript via unsanitized SVG favicons, leading to account takeover or server code execution.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 4 Jun 2025
- **Updated:** 4 Jun 2025
- **Also known as:** GHSA-f6r4-jrvc-cfmr

## What is CVE-2025-31136?

CVE-2025-31136 is a medium-severity cross-site scripting vulnerability in FreshRSS, published on 4 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

FreshRSS is a self-hosted RSS feed aggregator. Prior to version 1.26.2, it's possible to run arbitrary JavaScript on the feeds page.
This occurs by combining a cross-site scripting (XSS) issue that occurs in `f.php` when SVG favicons are downloaded from an attacker-controlled feed containing `<script>` tags inside of them that aren't sanitized, with the lack of CSP in `f.php` by embedding the malicious favicon in an iframe (that has `sandbox="allow-scripts allow-same-origin"` set as its attribute). An attacker needs to control one of the feeds that the victim is subscribed to, and also must have an account on the FreshRSS instance. Other than that, the iframe payload can be embedded as one of two options. The first payload requires user interaction (the user clicking on the malicious feed entry) with default user configuration, and the second payload fires instantly right after the user adds the feed or logs into the account while the feed entry is still visible. This is because of lazy image loading functionality, which the second payload bypasses. An attacker can gain access to the victim's account by exploiting this vulnerability. If the victim is an admin it would be possible to delete all users (cause damage) or execute arbitrary code on the server by modifying the update URL using fetch() via the XSS. Version 1.26.2 has a patch for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-31136?

It affects 1 product.


Products: Freshrss Freshrss.

## How do I fix CVE-2025-31136?

No fix has been published for CVE-2025-31136 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-31136 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-31136 exists.

## Other vulnerabilities in FreshRSS

- [CVE-2025-54875](https://insights.sbomify.com/CVE-2025-54875/): FreshRSS: Unauthorized creation of admin user when registration is enabled (critical 9.8)
- [CVE-2025-54592](https://insights.sbomify.com/CVE-2025-54592/): FreshRSS has Incomplete Session Termination on Logout (high 8.8)
- [CVE-2025-62166](https://insights.sbomify.com/CVE-2025-62166/): FreshRSS has an IDOR which allows for viewing feeds of any user and leaking tokens (high 7.5)
- [CVE-2025-54591](https://insights.sbomify.com/CVE-2025-54591/): FreshRSS: Unauthenticated users can view default user's information (high 7.5)
- [CVE-2025-58173](https://insights.sbomify.com/CVE-2025-58173/): FreshRSS vulnerable to authenticated RCE via path traversal inside include() (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31136 and fix it if it is affected.

What it is: CVE-2025-31136 is a medium-severity cross-site scripting vulnerability in FreshRSS, published on 4 Jun 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-31136 exists.

Affected product: FreshRSS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31136/ (Markdown: https://insights.sbomify.com/CVE-2025-31136/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31136
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31136
- OSV: https://osv.dev/vulnerability/CVE-2025-31136

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31136/
Summaries are generated and may contain mistakes; the official description above is the record.
