# CVE-2025-31200: Apple Multiple Products Memory Corruption

> Processing a malicious audio file allows code execution via memory corruption, affecting Apple operating systems and requiring immediate upgrades.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 17 Apr 2025 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Apr 2025
- **Updated:** 2 Apr 2026
- **Also known as:** GHSA-8f6m-fvf9-6397

## What is CVE-2025-31200?

CVE-2025-31200 is a critical memory corruption vulnerability in Apple Ipados, published on 16 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A memory corruption issue was addressed with improved bounds checking. This issue is fixed in iOS 18.4.1 and iPadOS 18.4.1, macOS Sequoia 15.4.1, tvOS 18.4.1, visionOS 2.4.1, watchOS 11.5. Processing an audio stream in a maliciously crafted media file may result in code execution. Apple is aware of a report that this issue may have been exploited in an extremely sophisticated attack against specific targeted individuals on versions of iOS released before iOS 18.4.1.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2025-31200?

It affects 6 products.


Products: Apple Ipados, Apple Iphone Os, Apple Macos, Apple Tvos, Apple Visionos, Apple Watchos.

## How do I fix CVE-2025-31200?

No fix has been published for CVE-2025-31200 yet. Limit exposure of the affected software until one is available. US federal agencies must fix it by 8 May 2025.

## Is CVE-2025-31200 being exploited?

Yes. Attackers have exploited CVE-2025-31200 in the wild since at least 17 Apr 2025.

Public exploit code:

- CVE-2025-31200 is a zero-day, zero-click RCE in iOS CoreAudio’s AudioConverterService, triggered by a malicious audio file via iMessage/SMS. Exploitation bypassed Blastdoor, enabled kernel escalation (CVE-2025-31201), and allowed token theft until patched in iOS 18.4.1 (Apr 16, 2025). (github_poc): https://github.com/JGoyd/iOS-Attack-Chain-CVE-2025-31200-CVE-2025-31201
- CVE-2025-31200 - @Noahhw46 figured it out (github_poc): https://github.com/zhuowei/apple-positional-audio-codec-invalid-header
- IOS audio buffer overflow CVE-2025-31200 POC (github_poc): https://github.com/hunters-sec/CVE-2025-31200
- Public disclosure of CVE-2025-31200 – Zero-click RCE in iOS 18.X via AudioConverterService and malicious audio file. (github_poc): https://github.com/serundengsapi/CVE-2025-31200-iOS-AudioConverter-RCE

## Other vulnerabilities in Apple Ipados

- [CVE-2025-43300](https://insights.sbomify.com/CVE-2025-43300/): Apple iOS, iPadOS, and macOS Out-of-Bounds Write (critical 10.0, exploited in the wild)
- [CVE-2025-24201](https://insights.sbomify.com/CVE-2025-24201/): Apple Multiple Products WebKit Out-of-Bounds Write (critical 10.0, exploited in the wild)
- [CVE-2025-24085](https://insights.sbomify.com/CVE-2025-24085/): Apple Multiple Products Use-After-Free (critical 10.0, exploited in the wild)
- [CVE-2025-31201](https://insights.sbomify.com/CVE-2025-31201/): Apple Multiple Products Arbitrary Read and Write (critical 9.8, exploited in the wild)
- [CVE-2022-22587](https://insights.sbomify.com/CVE-2022-22587/): Apple Memory Corruption (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31200 and fix it if it is affected.

What it is: CVE-2025-31200 is a critical memory corruption vulnerability in Apple Ipados, published on 16 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2025-31200 in the wild since at least 17 Apr 2025.

Affected product: Apple Ipados. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31200/ (Markdown: https://insights.sbomify.com/CVE-2025-31200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31200
- OSV: https://osv.dev/vulnerability/CVE-2025-31200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31200/
Summaries are generated and may contain mistakes; the official description above is the record.
